Question #664253 on Sikuli changed:

sam  posted a new comment:

Thank you very much. I took a look around to see if pytest is compatible
with Jython. It seems Pytest does not support Jython 2.5.3 and 2.7.  I
put some links below:

Therefore, I tried to import unittest and XMLTestrunner instead of
pytest. Some part of the code is shown below:

import unittest
from XMLTestRunner1 import *

suite = unittest.TestLoader().loadTestsFromTestCase(FlowCode_test)

result = XMLTestRunner(file("unittest.xml", "w")).run(suite)

However, I got this error message when I run the GUI:

Error caused by: Traceback (most recent call last): 
result = XMLTestRunner(file("unittest.xml", "w")).run(suite) File 
"C:\sikulix\sikulixapi.jar\Lib\", line 191, in run File 
"C:\sikulix\sikulix.jar\Lib\unittest\", line 70, in __call__ File 
"C:\sikulix\sikulix.jar\Lib\unittest\", line 99, in run File 
"C:\sikulix\sikulix.jar\Lib\unittest\", line 178, in 
_handleModuleFixture TypeError: coercing to Unicode: need string, NoneType type 

Interestingly, whenever I run the script on the command line using "java
-cp %JYTHON_HOME%jython.jar;%CLASSPATH% org.python.util.jython" command
everything looks fine and Sikuli runs.

Is there something that I am doing wrong?

Thank you

You received this question notification because your team Sikuli Drivers
is an answer contact for Sikuli.

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to