should first be a question

** Changed in: sikuli
       Status: New => Invalid

** Converted to question:

You received this bug notification because you are a member of Sikuli
Drivers, which is subscribed to Sikuli.

  Mac: NullPointerException when running via ssh

Status in Sikuli:

Bug description:
  Sikuli versions: 1.1.2, 1.1.3
  Mac OS: 10.13, 10.12, 10.10
  Java versions: 1.8, 1.9

  My sikuli script works fine when I run it from Sikuli IDE and from command 
line (without IDE). 
  But when I connect via ssh to the Mac where Sikuli is installed and run the 
same script, it fails with an error:
  [error] script [ /Users/shareduser/<path-to-script>/click_button.sikuli ] 
stopped with error in line 1
  [error] java.lang.NullPointerException ( java.lang.NullPointerException )

  The script 'click_button.sikuli' itself is very simple:
  click(<my image>)

  How do I run the script from command line:
  java -jar /Applications/ -r 
  (it works fine)

  How do I run the same script when I connect via ssh (I run the following 
command on a different Mac to run the script on the Mac where Sikuli is 
  ssh shareduser@ 'java -jar 
/Applications/ -r 
  (it fails with NullPointerException, see full error text above)

  I've tried different versions of Java, Mac OS and Sikuli, but the result is 
always the same.
  I'm out of options now.

  Any help will be highly appreciated.

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to