> Bibletime 2.10.1 (the SlackBuilds.org version) building fails under qt
> 5.7. 
> 
> I know that the Qt version required by bibletime is Qt4 IIRC, but Qt5
> is even in SBo and I think that 2.10.x fails to pick the correct Qt
> version and thus compilation fails.
> 
> This is fixed upstream in 2.11x branch, which now requires Qt5.
> 
> I was able to edit the SlackBuild for bibletime-2.11_rc2 and I got a
> successful compilation and package which runs fine on Qt5. (Just
> editing the version number and the name of the source file, and
> changing README for README.md on the /usr/doc package did the trick).
> 
> Thus, I would propose any of the following:
> 
> a) make sure bibletime 2.10.1 (current version) picks Qt4; or
> 
> b) upgrade to 2.11x branch and include Qt5 as a requirement.
> 
> Thank you!

Thanks for the report Eduardo,

For now, i have updated the README to include a note when building
bibletime.

As for the decision to upgrade to 2.11 or to edit the SlackBuild, i will
leave that to the maintainer (Tim).


-- 
Willy Sudiarto Raharjo

Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
SlackBuilds-users mailing list
SlackBuilds-users@slackbuilds.org
http://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
Archives - https://lists.slackbuilds.org/pipermail/slackbuilds-users/
FAQ - https://slackbuilds.org/faq/

Reply via email to