On Mon, 05 Mar 2018 12:37:08 -0800
Benjamin Trigona-Harany <slackbui...@jaxartes.net> wrote:

> On Monday, 5 March 2018 11:32:45 PST Frédéric Falsetti wrote:
> > QScintilla-qt5 configure fails with:
> > 
> > install -m 755 -p libqscintillaplugin.so
> > /tmp/SBo/package-QScintilla-qt5/usr/lib/qt5/plugins/designer/libqscintillap
> > lugin.so strip --strip-unneeded
> > /tmp/SBo/package-QScintilla-qt5/usr/lib/qt5/plugins/designer/libqscintillap
> > lugin.so /tmp/SBo/QScintilla_gpl-2.10.2
> > Usage: python configure.py [options]
> > 
> > configure.py: error: '/usr/bin/python-sip' is not an executable
> 
> I just pushed an update to my repo with a fix. However, I also noticed that 
> PyQt5 and python3-PyQt5 seem to write over eachother's files, so I recommend 
> uninstalling PyQt5 (QGIS doesn't need it) and reinstalling python3-PyQt5 to 
> make sure you don't have any incompatible files that might prevent QScintilla-
> qt5 from building properly.
> 
> Thanks for finding this issue!

now  QScintilla fails : No file or folder of this type:
> /usr/share/sip/PyQt5/QtWidgets/qwidget.sip:28:21: fatal error: qwidget.h 



> 
> _______________________________________________
> SlackBuilds-users mailing list
> SlackBuilds-users@slackbuilds.org
> https://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
> Archives - https://lists.slackbuilds.org/pipermail/slackbuilds-users/
> FAQ - https://slackbuilds.org/faq/
> 
_______________________________________________
SlackBuilds-users mailing list
SlackBuilds-users@slackbuilds.org
https://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
Archives - https://lists.slackbuilds.org/pipermail/slackbuilds-users/
FAQ - https://slackbuilds.org/faq/

Reply via email to