On Tuesday, 6 March 2018 18:13:18 PST Rich Shepard wrote:
> On Tue, 6 Mar 2018, Benjamin Trigona-Harany wrote:
> > rm -r python/plugins/GdalTools
> > make > output.log
> 
> Ben,
> 
>    Log file (about 3k smaller) is attached, and I think I see the problem.
> On the v.t. I see:
> 
> /usr/lib/gcc/i586-slackware-linux/5.5.0/../../../../i586-slackware-linux/bin
> /ld: warning: libproj.so.12, needed by
> /usr/lib/gcc/i586-slackware-linux/5.5.0/../../../libspatialite.so, not
> found (try using -rpath or -rpath-link)
> /usr/lib/gcc/i586-slackware-linux/5.5.0/../../../../i586-slackware-linux/bi
> n/ld: warning: libproj.so.12, needed by
> /usr/lib/gcc/i586-slackware-linux/5.5.0/../../../libspatialite.so, not
> found (try using -rpath or -rpath-link)
> /usr/lib/gcc/i586-slackware-linux/5.5.0/../../../../i586-slackware-linux/bi
> n/ld: warning: libproj.so.12, needed by
> /usr/lib/gcc/i586-slackware-linux/5.5.0/../../../libspatialite.so, not
> found (try using -rpath or -rpath-link)
> /usr/lib/gcc/i586-slackware-linux/5.5.0/../../../../i586-slackware-linux/bi
> n/ld: warning: libproj.so.12, needed by
> /usr/lib/gcc/i586-slackware-linux/5.5.0/../../../libspatialite.so, not
> found (try using -rpath or -rpath-link) Traceback (most recent call last):
>    File "../../../../../scripts/pyuic-wrapper.py", line 26, in <module>
>      import qgis.PyQt.uic.pyuic
>    File "/opt/SBo/qgis-2.18.17/build/output/python/qgis/__init__.py", line
> 27, in <module> from qgis.core import QgsFeature, QgsGeometry
>    File "/opt/SBo/qgis-2.18.17/build/output/python/qgis/core/__init__.py",
> line 30, in <module> from qgis._core import *
> ImportError: libproj.so.12: cannot open shared object file: No such file or
> directory make[2]: *** [python/plugins/GdalTools/tools/ui_widgetSieve.py]
> Error 1 make[1]: ***
> [python/plugins/GdalTools/tools/CMakeFiles/zzz-GdalTools-2-depend.dir/all]
> Error 2 make: *** [all] Error 2
> 
> and the build is looking for libproj.so.12. Here, libproj-4.4.7-i486-2 is
> installed and provides /usr/lib/libproj.so.13.
> 
> HTH,
> 
> Rich

Is it possible you installed proj 5.0.0? In any case, you've probably upgraded 
proj at some point and not recompiled everything that depends on it (at least 
gdal, libspatialite and postgis).

Rebuild those and try QGIS again and I'm betting it also builds.



_______________________________________________
SlackBuilds-users mailing list
SlackBuilds-users@slackbuilds.org
https://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
Archives - https://lists.slackbuilds.org/pipermail/slackbuilds-users/
FAQ - https://slackbuilds.org/faq/

Reply via email to