2018-03-13 12:15 GMT+01:00 Christoph Willing <chris.will...@iinet.net.au>:
> On 13/03/18 20:33, Ozan Türkyılmaz wrote:
>> I havent been able to compile retroshare but problem is not with libupnp
>> right now.
>>
>
> Yes, that patch is just a partial fix.
>
> The API for libupnp has changed in the new 1.8.x versions (SBo has
> libupnp-1.8.3 at the moment). Retroshare devs will need to update their
> code to utilize the new libupnp API.
>
> Without any indication of how long that might take, maybe we need a
> libupnp-legacy SlackBuild with version capped at the latest in the 1.6.x
> series so that retroshare can continue to be built. Otherwise we sit
> tight with a SlackBuild that won't build until upstream updates their code.

yes, I can confirm the issue seems still related to the newer libupnp

https://pastebin.com/raw/Yk07FRuA
_______________________________________________
SlackBuilds-users mailing list
SlackBuilds-users@slackbuilds.org
https://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
Archives - https://lists.slackbuilds.org/pipermail/slackbuilds-users/
FAQ - https://slackbuilds.org/faq/

Reply via email to