> On 13/03/18 20:04, Ythogtha wrote:
> > Hi everybody !
> > 
> >     it seems that ffmpeg can't compile with opencv version 3.4.1, here is
> > the message, it happens straight after the un-tar-ing of the source :
> > 
> > ####
> > [...]
> > ffmpeg-3.4/COPYING.LGPLv2.1
> > ffmpeg-3.4/README.md
> > ffmpeg-3.4/CONTRIBUTING.md
> > ERROR: opencv not found
> > 
> > If you think configure made a mistake, make sure you are using the latest
> > version from Git.  If the latest version fails, report the problem to the
> > ffmpeg-u...@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
> > Include the log file "ffbuild/config.log" produced by configure as this will
> > help solve the problem.
> > ####
> > 
> > Opencv 3.4.1 does seem to work on its own.
> > ffmpeg compiles fine with OpenCV 3.4.0.
> > ffmpeg does not work when compiled against OpenCV 3.4.0, if OpenCV is
> > updated to 3.4.1 - but that was to be expected, ffmpeg is pretty touchy with
> > specific versions of the libraries it uses.
> > 
> > The error is the same if I try with ffmpeg 3.4.2 (the latest).
> > 
> > I don't have a solution, and I just wanted to point that out, since I don't
> > really use OpenCV, so I can compile my ffmpeg without it (or with the
> > previous version). I just like my ffmpeg bloated with options ^^
> > 
> 
> An interesting problem - opencv is optional for ffmpeg and ffmpeg is
> optional for opencv i.e. an optional circular dependency.
> 
> chris

Yep, that's pretty funny :)
        Though in the past it wasn't very difficult to handle.
Opencv can be built against ffmpeg even if ffmpeg doesn't run because you just
removed the opencv against which it was built, and rebuilding ffmpeg with the
new opencv after that doesn't break opencv. (You follow me ? :))
        So well usually, when one of them is updated, you just had to rebuild
it, install it, then rebuild the other one.
        I haven't tested going at it from scratch on a clean 14.2 VM, but the
error doesn't suggest there is a side effect of this circular dependency.
Something changed in OpenCV 3.4.1, and ffmpeg can't find it anymore.
And the git diff on opencv's slackbuild does not help me there either, it was a
pretty simple version bump.

-- 
Arnaud <y...@ythogtha.org>
_______________________________________________
SlackBuilds-users mailing list
SlackBuilds-users@slackbuilds.org
https://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
Archives - https://lists.slackbuilds.org/pipermail/slackbuilds-users/
FAQ - https://slackbuilds.org/faq/

Reply via email to