I don't think cblas was previously installed.  However, my
sbopkg-pkg-log does have references to cblas in numpy, pygsl, and other
places. I suppose it is possible that something unique to my computer
triggered the need for cblas.  OTB was part of a long sbopkg queuefile
and OpenBLAS was higher up on the list.The "blas" packages are confusing
to me, but I guess the alternate blas routines can be used even though
the generic blas is installed.  I was trying to get qgis and
dependencies/options installed, which did work out pretty well except
for libaspacialite not linking to postgis.

Thanks

On 08/11/2018 01:44 PM, Benjamin Trigona-Harany wrote:
> On Thursday, 9 August 2018 10:43:25 PDT Kevin McCormick wrote:
>> Build failed for OTB:
>> OTB 6.6.0 undefined reference to `cblas_dgemm'
>>
>> After installing "cblas" (in addition to the other requirements) the
>> build was successful.  The requirements list "blas" but not "cblas."
>>
>> I did not set the MONTEVERDI=ON switch.
>>
>> Thanks
> I have not been able to recreate this issue. OTB builds fine on Slackware 64 
> 14.2 with blas and not cblas installed. Is it possible you are linking 
> against 
> another of OTB's dependencies that were previously built when cblas was 
> installed?
>
>
>

_______________________________________________
SlackBuilds-users mailing list
SlackBuilds-users@slackbuilds.org
https://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
Archives - https://lists.slackbuilds.org/pipermail/slackbuilds-users/
FAQ - https://slackbuilds.org/faq/

Reply via email to