I have *finally* got Slide to work on WebSphere

I am posting this information to help others that may be experiencing the same problems that I ran into.

1. Checkout current CVS version (You may also be able to use a release or milestone version).

2. Replace double-quotes around UTF-8 instances in the following file:

       from: res.setContentType("text/html; charset=\"UTF-8\"");
         to: res.setContentType("text/html; charset=UTF-8");

This should fix the UTF errors/warnings that you see in the log files.

3. Rename src/conf/ojb/log4j.properties to log4j.xproperties.

This fixes problem with WebSphere complaining about corrupt war due to multiple log4j.properties files in war.

4. Build slide webapp (ant webapp-dist).

5. Change WebSphere/AppServer/config/cells/plugin-cfg.xml to have AcceptAllContent="true".

This should fix the problem of seeing the list of files and then showing the same list again when you try and open a folder.

6. Rename jdom.jar to jdom.xjar in WebSphere/AppServer/lib.

This is to use more recent jdom distributed with slide. You may also try using ear/war parent-last classloading or using a shared library instead.

7. Start WebSphere server.

8. Install slide.war

9. Change slide WEB-INF/classes/slide.properties: org.apache.slide.security=false

This may not be necessary depending on your security setup, but you may want to try it to get up and running.

10. Start slide.war application.

This process worked for me allowing access via WebFolders and MS/Word under MS/XP SP2 (your mileage may vary).

Good luck and many thanks to the Slide team for a great product.

To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to