Marco,

It seems that your application is reading the slurm.conf, if it is an ompss
application maybe you need to recompile the application or the runtime with
your modifications to slurm in order for it to understand the new parameter.

Regards,
Carlos

On Fri, Sep 16, 2016 at 2:05 PM, Marco D'Amico <marco.damic...@gmail.com>
wrote:

> Hi Sergio,
> yes the slurm.h and slurm.h.in are ok.
>
> Il giorno ven 16 set 2016 alle ore 08:42 Sergio Iserte <sise...@uji.es>
> ha scritto:
>
>> Marco,
>> could you check that files src/slurm/slurm.h.in and src/slurm/slurm.h have
>> the parameter?
>>
>> I'm not sure, I'm just speculating..., but the second file is
>> autogenerated when configuring.
>>
>> Sergio.
>>
>>
>>
>> 2016-09-15 17:59 GMT+02:00 Marco D'Amico <marco.damic...@gmail.com>:
>>
>>> Same problem also as a normal slurm.conf parameter, and also changing
>>> slurm version (from 15.08.10 to 16.05.4)
>>>
>>> Marco
>>>
>>>
>>> Il giorno gio 15 set 2016 alle ore 12:45 Marco D'Amico <
>>> marco.damic...@gmail.com> ha scritto:
>>>
>>>> Hi,
>>>> I am trying to add a new parameter in slurm.conf in the partition part
>>>> of the script, so I edited all structures and functions in order to work
>>>> with it.
>>>> When slurm daemons read the slurm.conf I have no parsing problems and
>>>> it looks everything is going fine, but then when the application is
>>>> launched I have the following error:
>>>>
>>>> mpi_ompss_pils: error: Parsing error at unrecognized key: SharingFactor
>>>> mpi_ompss_pils: error: Parse error in file /......../slurm.conf line
>>>> 207: " SharingFactor=0.3"
>>>> srun: error: slurm_receive_msg: Zero Bytes were transmitted or received
>>>> srun: error: slurm_receive_msg[10.2.1.32]: Zero Bytes were transmitted
>>>> or received
>>>> srun: error: slurm_receive_msg: Zero Bytes were transmitted or received
>>>> srun: error: slurm_receive_msg[10.2.1.32]: Zero Bytes were transmitted
>>>> or received
>>>> srun: error: s01r1b32: tasks 0-1: Segmentation fault
>>>>
>>>> Why my application is reading slurm.conf again? And why now the
>>>> parameter is not recognized?
>>>> Any help is appreciated,
>>>> Thanks
>>>>
>>>
>>
>>
>> --
>> Sergio Iserte
>> High Performance Computing & Architectures (HPCA)
>> Department of Computer Science and Engineering (DICC)
>> Universitat Jaume I (UJI)
>>
>>


-- 
--
Carles Fenoy

Reply via email to