Hi,

I'm trying to build slurm on Ubuntu 14.04 with kernel 3.16.0-77-generic (due to limitations of lustre and blcr).


I'm running into a problem with lz4. I have installed the following ubuntu packages...

liblz4-dev

liblz4-1

liblz4-tool

...but I get the following in the ./configure

checking if lz4 is installed... yes /usr/local /usr /opt/local /sw
checking for LZ4_compress_destSize in -llz4... no
checking lz4.h usability... yes
checking lz4.h presence... yes
checking for lz4.h... yes
configure: WARNING: LZ4 test program build failed.

I tried pointing it at a build of the latest lz4 from source (https://github.com/lz4/lz4/releases/tag/v1.7.5 <https://github.com/lz4/lz4/releases/tag/v1.7.5>) but I still get the same.

The lz4.h file doesn't contain LZ4_compress_destSize and neither does the symbol appear in the lz4.so file :

# nm -D liblz4.so
0000000000208050 B __bss_start
                 U calloc
                 w __cxa_finalize
0000000000208050 D _edata
0000000000208058 B _end
0000000000006818 T _fini
                 U free
                 w __gmon_start__
0000000000000ed0 T _init
                 w _ITM_deregisterTMCloneTable
                 w _ITM_registerTMCloneTable
                 w _Jv_RegisterClasses
0000000000001080 T LZ4_compress
0000000000001050 T LZ4_compressBound
0000000000003140 T LZ4_compress_continue
00000000000065c0 T LZ4_compressHC
0000000000006560 T LZ4_compressHC2
00000000000067c0 T LZ4_compressHC2_continue
00000000000065d0 T LZ4_compressHC2_limitedOutput
0000000000006800 T LZ4_compressHC2_limitedOutput_continue
0000000000006700 T LZ4_compressHC2_limitedOutput_withStateHC
0000000000006660 T LZ4_compressHC2_withStateHC
00000000000067a0 T LZ4_compressHC_continue
0000000000006640 T LZ4_compressHC_limitedOutput
00000000000067e0 T LZ4_compressHC_limitedOutput_continue
0000000000006790 T LZ4_compressHC_limitedOutput_withStateHC
00000000000066f0 T LZ4_compressHC_withStateHC
0000000000001790 T LZ4_compress_limitedOutput
0000000000003510 T LZ4_compress_limitedOutput_continue
0000000000002740 T LZ4_compress_limitedOutput_withState
0000000000002010 T LZ4_compress_withState
0000000000003010 T LZ4_create
00000000000062e0 T LZ4_createHC
0000000000004aa0 T LZ4_decompress_fast
00000000000046c0 T LZ4_decompress_fast_withPrefix64k
0000000000003950 T LZ4_decompress_safe
0000000000004240 T LZ4_decompress_safe_partial
0000000000003dc0 T LZ4_decompress_safe_withPrefix64k
0000000000003060 T LZ4_free
0000000000006350 T LZ4_freeHC
0000000000002fc0 T LZ4_resetStreamState
0000000000006280 T LZ4_resetStreamStateHC
0000000000002000 T LZ4_sizeofState
0000000000006650 T LZ4_sizeofStateHC
0000000000002fb0 T LZ4_sizeofStreamState
0000000000006270 T LZ4_sizeofStreamStateHC
0000000000003070 T LZ4_slideInputBuffer
0000000000006360 T LZ4_slideInputBufferHC
0000000000004e80 T LZ4_uncompress
0000000000004e90 T LZ4_uncompress_unknownOutputSize
                 U memcpy
                 U memset

Anyone got any ideas on how to get an lz4 library on ubuntu that slurm will like ?

Regards,

Emyr




--
The Wellcome Trust Sanger Institute is operated by Genome Research Limited, a charity registered in England with number 1021457 and a company registered in England with number 2742969, whose registered office is 215 Euston Road, London, NW1 2BE.

Reply via email to