This is due to newer versions of SLURM using /sys/fs/cgroup (as in RHEL7)
rather than /cgroup (as in RHEL6). It would have been a no-brainer to check
and do the right thing, but as it is, you have to specify the cgroup mount
point in cgroup.conf if you're on the wrong system for your slurm version.

slurmd could be a little more explicit with its error messages...

On Sat, Aug 12, 2017 at 6:38 AM, Somayah H <somayahass...@gmail.com> wrote:

> Hi Slurm-Dev,
>
> I again tried setting up SLURM but it is not able to setup the cgroups.
>
> I tried setting up the cgroups manually, but I am getting the error that
> the filesystem of type cgroup is unknown. I looked around for some solution
> but have been unable to find it.  Does anyone have any recommended
> solution to fix this issue?
>
> root@mini12:/home/utilite# slurmd -cDvvv
> slurmd: topology NONE plugin loaded
> slurmd: debug:  Reading cgroup.conf file /etc/slurm-llnl/cgroup.conf
> slurmd: debug2: unable to open '/cgroup/freezer//release_agent' for
> reading : No such file or directory
> slurmd: debug2: unable to get parameter 'release_agent' for
> '/cgroup/freezer/'
> mount: unknown filesystem type 'cgroup'
> slurmd: error: unable to mount freezer cgroup namespace
> slurmd: error: Couldn't load specified plugin name for proctrack/cgroup:
> Plugin init() callback failed
> slurmd: error: cannot resolve proctrack plugin operations for
> proctrack/cgroup
> slurmd: error: slurmd initialisation failed
>
>
> Thanks.
>

Reply via email to