Are you using the internal VNC in the KVM? I believe certain VNC clients are 
incompatible.

Sent from cyberspace

> On 18 Sep 2016, at 16:20, G B via smartos-discuss 
> <smartos-discuss@lists.smartos.org> wrote:
> 
> I'm running SmartOS 20160818T234814Z and using freebsd-10 20160415 in a KVM.  
> I've installed a number of window managers but the mouse never works.  Has 
> anyone been able to use a window manager like WindowMaker, wmii, twm, etc., 
> over Xming?
> 
> I tried generating an xorg.conf which typically isn't needed, but it doesn't 
> work.  Here are the contents.
> Section "ServerLayout"
>     Identifier     "X.org Configured"
>     Screen      0  "Screen0" 0 0
>     InputDevice    "Mouse0" "CorePointer"
>     InputDevice    "Keyboard0" "CoreKeyboard"
> EndSection
> 
> Section "Files"
>     ModulePath   "/usr/local/lib/xorg/modules"
>     FontPath     "/usr/local/share/fonts/misc/"
>     FontPath     "/usr/local/share/fonts/TTF/"
>     FontPath     "/usr/local/share/fonts/OTF/"
>     FontPath     "/usr/local/share/fonts/Type1/"
>     FontPath     "/usr/local/share/fonts/100dpi/"
>     FontPath     "/usr/local/share/fonts/75dpi/"
> EndSection
> 
> Section "Module"
>     Load  "glx"
> EndSection
> 
> Section "InputDevice"
>     Identifier  "Keyboard0"
>     Driver      "kbd"
> EndSection
> 
> Section "InputDevice"
>     Identifier  "Mouse0"
>     Driver      "mouse"
>     Option        "Protocol" "auto"
>     Option        "Device" "/dev/sysmouse"
>     Option        "ZAxisMapping" "4 5 6 7"
> EndSection
> 
> Section "Monitor"
>     Identifier   "Monitor0"
>     VendorName   "Monitor Vendor"
>     ModelName    "Monitor Model"
> EndSection
> 
> Section "Device"
>         ### Available Driver options are:-
>         ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
>         ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
>         ### <percent>: "<f>%"
>         ### [arg]: arg optional
>         #Option     "ShadowFB"               # [<bool>]
>         #Option     "DefaultRefresh"         # [<bool>]
>         #Option     "ModeSetClearScreen"     # [<bool>]
>     Identifier  "Card0"
>     Driver      "vesa"
>     BusID       "PCI:0:2:0"
> EndSection
> 
> Section "Screen"
>     Identifier "Screen0"
>     Device     "Card0"
>     Monitor    "Monitor0"
>     SubSection "Display"
>         Viewport   0 0
>         Depth     1
>     EndSubSection
>     SubSection "Display"
>         Viewport   0 0
>         Depth     4
>     EndSubSection
>     SubSection "Display"
>         Viewport   0 0
>         Depth     8
>     EndSubSection
>     SubSection "Display"
>         Viewport   0 0
>         Depth     15
>     EndSubSection
>     SubSection "Display"
>         Viewport   0 0
>         Depth     16
>     EndSubSection
>     SubSection "Display"
>         Viewport   0 0
>         Depth     24
>     EndSubSection
> EndSection
> 
> 
> 
> smartos-discuss | Archives  | Modify Your Subscription         



-------------------------------------------
smartos-discuss
Archives: https://www.listbox.com/member/archive/184463/=now
RSS Feed: https://www.listbox.com/member/archive/rss/184463/25769125-55cfbc00
Modify Your Subscription: 
https://www.listbox.com/member/?member_id=25769125&id_secret=25769125-7688e9fb
Powered by Listbox: http://www.listbox.com

Reply via email to