: But I am getting below exception when i run update or through DIH. Please
: let me know how to fix this.
: java.lang.NullPointerException
:         at

That's a really weird error.

I don't *think* Reth's suggestion will have any barring on the outcome, 
but i would love to hear if it changes anything.

the method name "getDefaultValue" in that stack trace is just 
because of how the class implements the general contract of a 
DefaultValueUpdateProcessor -- what that specific line is doing in 5.2.1 
is accessing the definition of "NOW" for the Solr Request -- metadata that 
is initialized when the request is first initiated (to ensure that a 
consistent value is used if, for example, multiple date based facets 
are computed i na single request, or multiple docs are added in a single 

If you *only* got thsi error when using DIH, I would guess maybe DIH has a 
bug when it creates it's internal requests (because it's operating 
asynchronously) that prevents this value from getting initialized properly 
-- but you said "getting below exception when i run update or through DIH" 
... impliying that you get teh same exception when you do updates in other 

can you confirm/deny that you get a similar exception if/when you send 
updates *not* from DIH, and if so can you please show us the full stack 
trace of the error in that situation and provide some details regarding 
how you sent the update that caused that exception?


Reply via email to