Greetings, Apache Solr community.

I'm here to ask for your help and advice about a Solr-related problem I'm 

My company is an e-commerce website and uses Solr in production for the 
querying of items in our inventory. The Solr installation was done by an 
engineer who has left the company. About 2 weeks ago, Solr stopped working 
completely (our website wasn't rendering completely and we lost the search 

We also couldn't access the Solr dashboard, located in our server at 

(NB - Solr runs on ports 8282 in our server.)

I logged onto the remote server where Solr was installed and ran
> bin/solr status

I got this message -
Found 1 Solr nodes:

Solr process 4365 running on port 8282

ERROR: Failed to get system information from https://localhost:8282/solr due 
to: Certificate for doesn't match any of the 
subject alternative names: [*,]

We figured that it could be an SSL issue and tried accessing the Solr dashboard 
through plain HTTP by plugging in our server's IP address. This time, we could 
access the Solr dashboard. But our website works solely by https, so the Solr 
query gets blocked every time.

It seems that only https connections are being blocked by Solr and its port 
(8282). Everything works fine on the other ports, and on http.

We contacted our SSL certificate authority, and they said everything was fine 
from their end. They even made us perform openssl tests and send them the 
output. but they couldn't find anything cause from their end. (I have the 
openssl messages returned from the tests, which are long. I can share them if 
someone needs it)

What could be the issue here? I have tried so many things in order to fix this 
to no avail. Does anybody know what's going on and help a user out?

Thank you for your patience,

Here is a summary of the problem -

- Solr dashboard (located on is not 
- Only port 8282 (which Solr runs on is affected).  Services also running on on other ports are running fine.
- Solr throws a error.

- We discover we are able to access the Solr dashboard by looking up the IP 
address of our server (and not the URL) on http 
- Our platform runs soleley on HTTPS, so we're not able to go around it by 
using http.
- Our SSL certificate authority couldn't find a cause on their end.

Reply via email to