On Mon, 30 Nov 2015, Christos Zoulas wrote:

In article <20151130224719.7d1b...@cvs.netbsd.org>,
Paul Goyette <source-changes-d@NetBSD.org> wrote:
-=-=-=-=-=-

+       const struct sc_auto *auto_list;
+       int code;

That should be u_int.

Will fix.

-                       if (module_autoload(syscalls_autoload[i].al_module,
-                           MODULE_CLASS_ANY) != 0 ||
+                       if (module_autoload(auto_list->al_module,
+                                           MODULE_CLASS_ANY) != 0 ||

KNF.

Will fix.

+#      autoloadprefix  the prefix for the autoload table name

Why isn't that the emulation name?

Let me check on this one...

+ * Autoloadable syscall definition
+ */
+struct sc_auto {
+       u_int           al_code;
+       const char      *al_module;
+};

A better name would be sc_autoload.

Will fix.


+------------------+--------------------------+------------------------+
| Paul Goyette     | PGP Key fingerprint:     | E-mail addresses:      |
| (Retired)        | FA29 0E3B 35AF E8AE 6651 | paul at whooppee.com   |
| Kernel Developer | 0786 F758 55DE 53BA 7731 | pgoyette at netbsd.org |
+------------------+--------------------------+------------------------+

Reply via email to