CVSROOT: /cvs Module name: src Changes by: t...@cvs.openbsd.org 2023/05/08 08:51:00
Modified files: lib/libcrypto/x509: x509_local.h x509_vfy.c Log message: Rename the other_ctx in X509_STORE_CTX into trusted The other_ctx is a strong contender for the worst name of a struct member in OpenSSL. It's a void * member whose only purpose ever was to be set to a STACK_OF(X509) * via X509_STORE_CTX_trusted_stack() (yes, this is obviously a setter, why do you ask?) and then to be used by the get_issuer() callback (which of course isn't there to find any old issuer, but only to look for issuers among the 'trusted' certs). Anyway, we may want to rename untrusted into intermediates and trusted into roots later on, but for now let's match the lovely public API. While there rename get_issuer_sk() into get_trusted_issuer() which is a more accurate and slightly less silly name. ok jsing