CVSROOT:        /cvs
Module name:    src
Changes by:        2023/06/06 10:20:13

Modified files:
        lib/libcrypto/man: X509_get0_notBefore.3 

Log message:
In 1995, Eric A. Young chose a confusing name for the "lastUpdate" field
of the X509_CRL_INFO object.  It should have been called "thisUpdate"
like in RFC 5280 section 5.1 (and in its precursor RFC 2459).  Then again,
RFC 2459 was only published in 1999, so maybe the terminology wasn't
firmly established yet when Young wrote his code several years earlier -
just guessing, neither we nor the OpenSSL folks appear to know the real

Anyway, we have been stuck with the "lastUpdate" names in the API for
more than two decades now, so clarify in the documentation what they
refer to and what they really mean.

Requested by and OK tb@.

Reply via email to