Thank you very much. This solution worked. 

Date: Wed, 6 Oct 2010 15:07:20 -0500
Subject: Re: [Spacewalk-list] Spacewalk Client Install on Solaris 10

Try this:

I was having the same issue because the scripts were calling the native python. 
Once I put the redhat directories first in my path, it worked fine.
I put this in a file that I source only when I'm going to work with rhn on 


On Oct 6, 2010, at 12:30 PM, <> <> wrote:

I've installed the spacewalk client on Solaris 10, but attempts to register to 
the spacewalk server fail.  Hopefully someone will tell me what very small 
thing I have to do to make this work. Here are the details 
1 a)The error registering the Solaris10 client
# rhnreg_ks --force --serverUrl=http://myspacewalkserver/XMLRPC 
Traceback (most recent call last):
  File "/opt/redhat/rhn/solaris/usr/sbin/rhnreg_ks", line 28, in ?
    from rhn.client.translate import _
  File "/opt/redhat/rhn/solaris/lib/python2.4/site-packages/rhn/", 
line 11, in ?
    import rpclib
  File "/opt/redhat/rhn/solaris/lib/python2.4/site-packages/rhn/", 
line 14, in ?
    import transports
  File "/opt/redhat/rhn/solaris/lib/python2.4/site-packages/rhn/", 
line 24, in ?
    import connections
"/opt/redhat/rhn/solaris/lib/python2.4/site-packages/rhn/", line 
14, in ?
    import SSL
  File "/opt/redhat/rhn/solaris/lib/python2.4/site-packages/rhn/", line 
15, in ?
    from OpenSSL import SSL, crypto
"/opt/redhat/rhn/solaris/lib/python2.4/site-packages/OpenSSL/", line 
11, in ?
    import rand, crypto, SSL, tsafe
ImportError: python: fatal: relocation error: file 
/opt/redhat/rhn/solaris/lib/python2.4/site-packages/OpenSSL/ symbol 
PyUnicodeUCS4_Decode: referenced symbol not found

1 a)Just for reference this registration works from my RHEL5 client
#rhnreg_ks --force --serverUrl=http://myspacewalkserver/XMLRPC 
This system is not subscribed to any channels.
RHN channel support will be disabled.
2)The effective path for the registration session
#echo $PATH
3)The effective library paths
#crle -c /var/ld/ld.config
Configuration file [version 4]: /var/ld/ld.config
  Default Library Path (ELF):   
  Trusted Directories (ELF):    /lib/secure:/usr/lib/secure  (system default)
Command line:
  crle -c /var/ld/ld.config -l 
4)Supporting packages installed
#pkginfo SUNWzlib SUNWgccruntime
system      SUNWgccruntime GCC Runtime libraries
system      SUNWzlib       The Zip compression library
# pkginfo |grep -i openssl
utility     RHATpossl                        pyOpenSSL 0.6
application SMCossl                          openssl
system      SUNWopenssl-commands             OpenSSL Commands (Usr)
system      SUNWopenssl-include              OpenSSL Header Files
system      SUNWopenssl-libraries            OpenSSL Libraries (Usr)
system      SUNWopenssl-man                  OpenSSL Manual Pages
system      SUNWopensslr                     OpenSSL (Root)
5)Spacewalk packages i
#pkginfo|grep RHAT
utility     RHATpossl                        pyOpenSSL 0.6
utility     RHATpythn                        python 2.4.1
utility     RHATrcfg                         rhncfg 5.1.0
utility     RHATrcfga                        rhncfg-actions 5.1.0
utility     RHATrcfgc                        rhncfg-client 5.1.0
utility     RHATrcfgm                        rhncfg-management 5.1.0
utility     RHATrhnc                         rhnclient 5.1.0
utility     RHATrhnl                         rhnlib 1.8
utility     RHATrpush                        rhnpush 5.1.1
utility     RHATsmart                        smartpm 5.1.1

6)The server
 uname  -a
SunOS myservername 5.10 Generic_142901-10 i86pc i386 i86pc


_______________________________________________ Spacewalk-list mailing list                          
Spacewalk-list mailing list

Reply via email to