Check to make sure they aren't showing up in the Channels, Manage Software 
Channels, Manage Software Packages view under Channel: Packages in no channels.

When you delete a package from all channels, it's orphaned from all channels 
but still in the database and file system.  If you delete it from the "Packages 
in no channels view", it'll be deleted from the database and filesystem.

Regards,
--Tony




-----Original Message-----
From: spacewalk-list-boun...@redhat.com 
[mailto:spacewalk-list-boun...@redhat.com] On Behalf Of Steve Meier
Sent: Thursday, September 22, 2016 3:06 PM
To: spacewalk-list@redhat.com
Subject: [Spacewalk-list] spacewalk-data-fsck not working

Hello all,

I have been playing with Spacewalk 2.5 today and after synching some packages I 
did not want, I tried to remove them entirely from Spacewalk. As an example I 
have picked the "kernel-doc"
package.

First, I looked for them in the file system:

[root@spacewalk ~]# find /var/satellite -name 'kernel-doc*' -type f 
/var/satellite/redhat/1/a2b/kernel-doc/2.6.32-642.4.2.el6/noarch/a2b8e7402c375a214974398310b3337e1b6bfd75732048436b0be84358fc0151/kernel-doc-2.6.32-642.4.2.el6.noarch.rpm
/var/satellite/redhat/1/ffe/kernel-doc/2.6.32-642.el6/noarch/ffe2aea53a54accc295cfc38a66d8341ac7ca8eccbc5b35a8a313ea3865e00fa/kernel-doc-2.6.32-642.el6.noarch.rpm
/var/satellite/redhat/1/daf/kernel-doc/2.6.32-642.1.1.el6/noarch/dafcbcca6b84b865ad490ddd8c0bc769eda11f6291d9e3addbfe7f4ec4dc3b82/kernel-doc-2.6.32-642.1.1.el6.noarch.rpm
/var/satellite/redhat/1/8b4/kernel-doc/2.6.32-642.3.1.el6/noarch/8b48620cc50f738fc906f03bcc4c9180462f1ed83ee090431fcef05184a2263b/kernel-doc-2.6.32-642.3.1.el6.noarch.rpm

Revision 642 is from the CentOS 6 Base channel, while the other three are from 
the Updates channel.
I deleted all four of them through the "Manage Software Channels" menu. 
 From experience with earlier
versions I knew that this would only remove them from the database but not from 
the file system.

So next, I ran spacewalk-data-fsck with different parameters:

[root@spacewalk ~]# spacewalk-data-fsck -v Checking if packages from database 
are present on filesystem
  7094 files scanned
Checking if packages from filesystem are present in database
  7094 files scanned
[root@spacewalk ~]# spacewalk-data-fsck -f -r [root@spacewalk ~]# 
spacewalk-data-fsck -f -r -v Checking if packages from filesystem are present 
in database
  7094 files scanned

However, all four RPM files are still around and spacewalk-data-fsck does not 
seem to remove them although the -f option should do exactly that, if I read 
the man page correctly.

Is this a bug or am I just using it wrong? Thanks!

Kind regards,
   Steve

_______________________________________________
Spacewalk-list mailing list
Spacewalk-list@redhat.com
https://www.redhat.com/mailman/listinfo/spacewalk-list

_______________________________________________
Spacewalk-list mailing list
Spacewalk-list@redhat.com
https://www.redhat.com/mailman/listinfo/spacewalk-list

Reply via email to