Hi Gang,
                We are having some issues with a fresh install of Spacewalk 2.6 
on RHEL7.  The service starts up, and I can sync packages, however when I can’t 
register clients.  When trying to register a client using the rhnreg_ks 
program, I get the following server side error:

==> ssl_error_log <==
[Tue Aug 08 08:26:43.364508 2017] [:error] [pid 28337] [client x:38776] 
mod_wsgi (pid=28337): Exception occurred processing WSGI script 
'/usr/share/rhn/wsgi/xmlrpc.py'.
[Tue Aug 08 08:26:43.364585 2017] [:error] [pid 28337] [client x:38776] 
Traceback (most recent call last):
[Tue Aug 08 08:26:43.364614 2017] [:error] [pid 28337] [client x:38776]   File 
"/usr/share/rhn/wsgi/xmlrpc.py", line 22, in application
[Tue Aug 08 08:26:43.364746 2017] [:error] [pid 28337] [client x:38776]     
return wsgiHandler.handle(environ, start_response, "xmlrpc", "server.xmlrpc")
[Tue Aug 08 08:26:43.364773 2017] [:error] [pid 28337] [client x:38776]   File 
"/usr/share/rhn/wsgi/wsgiHandler.py", line 35, in handle
[Tue Aug 08 08:26:43.364843 2017] [:error] [pid 28337] [client x:38776]     
parseServ = get_handle(servertype, "HeaderParserHandler")
[Tue Aug 08 08:26:43.364867 2017] [:error] [pid 28337] [client x:38776]   File 
"/usr/share/rhn/wsgi/wsgiHandler.py", line 63, in get_handle
[Tue Aug 08 08:26:43.364905 2017] [:error] [pid 28337] [client x:38776]     
handler_module = __import__(servertype, globals(), locals(), 
[servertype.split('.')[-1]])
[Tue Aug 08 08:26:43.364925 2017] [:error] [pid 28337] [client x:38776]   File 
"/usr/lib/python2.7/site-packages/spacewalk/server/apacheServer.py", line 17, 
in <module>
[Tue Aug 08 08:26:43.364983 2017] [:error] [pid 28337] [client x:38776]     
from apacheHandler import apacheHandler
[Tue Aug 08 08:26:43.365005 2017] [:error] [pid 28337] [client x:38776]   File 
"/usr/lib/python2.7/site-packages/spacewalk/server/apacheHandler.py", line 42, 
in <module>
[Tue Aug 08 08:26:43.365102 2017] [:error] [pid 28337] [client x:38776]     
class apacheSession(rhnApache):
[Tue Aug 08 08:26:43.365135 2017] [:error] [pid 28337] [client x:38776] 
TypeError: Error when calling the metaclass bases
[Tue Aug 08 08:26:43.365168 2017] [:error] [pid 28337] [client x:38776]     
module.__init__() takes at most 2 arguments (3 given)

                From the client, I see:

root@host [development] ~ $ /usr/sbin/rhnreg_ks --force 
--activationkey=1-patchmonkey-sl6-x86_64 --serverUrl 
https://server-name-removed-for-emailing/XMLRPC
An error has occurred:
rhn-plugin: Error communicating with server. The message was:
Internal Server Error
See /var/log/up2date for more information
root@host [development] ~ $ tail -30 /var/log/up2date
Traceback (most recent call last):
  File "/usr/sbin/rhnreg_ks", line 217, in <module>
    cli.run()
  File "/usr/share/rhn/up2date_client/rhncli.py", line 96, in run
    sys.exit(self.main() or 0)
  File "/usr/sbin/rhnreg_ks", line 95, in main
    rhnreg.getCaps()
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 264, in getCaps
    s.capabilities.validate()
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 185, in 
__get_capabilities
    self.registration.welcome_message()
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 67, in __call__
    return rpcServer.doCall(method, *args, **kwargs)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 290, in doCall
    raise_with_tb(up2dateErrors.CommunicationError(e.errmsg))
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 214, in doCall
    ret = method(*args, **kwargs)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1199, in __call__
    return self.__send(self.__name, args)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 48, in _request1
    ret = self._request(methodname, params)
  File "/usr/lib/python2.6/site-packages/rhn/rpclib.py", line 394, in _request
    self._handler, request, verbose=self._verbose)
  File "/usr/lib/python2.6/site-packages/rhn/transports.py", line 177, in 
request
    headers, fd = req.send_http(host, handler)
  File "/usr/lib/python2.6/site-packages/rhn/transports.py", line 740, in 
send_http
    response.status, response.reason, response.msg)
<class 'up2date_client.up2dateErrors.CommunicationError'>: rhn-plugin: Error 
communicating with server. The message was:
Internal Server Error

                I’ve also tried registering using a username/password instead 
of the activation key, which produces the same error.  Both client and server 
are up to date from the spacewalk repos.

                Any thoughts on what I’m missing?  Thanks!!


--
Drew Stinnett
Duke University
OIT-SSI-Systems

_______________________________________________
Spacewalk-list mailing list
Spacewalk-list@redhat.com
https://www.redhat.com/mailman/listinfo/spacewalk-list

Reply via email to