Check your os locale by typing    locale

I guess that they will all say UTF8 except there will be no value for lc_all. 
If that's the case, do (or match the other locale strings for your location, 
but it needs to have UTF8 in it.
export LC_ALL=en-us.UTF8

Then try installing again.

Sent from Nine<http://www.9folders.com/>
________________________________
From: Felipe Westfields <felipe.westfie...@gmail.com>
Sent: Thursday, February 1, 2018 10:55 PM
To: spacewalk-list@redhat.com
Subject: [Spacewalk-list] Database error when installing Space-Walk 2.7

I'm installing Spacewalk on CentOS 7, Spacewalk 2.7, following the instructions 
on this page:

https://github.com/spacewalkproject/spacewalk/wiki/HowToInstall

I install the the necessary repos, all seems well. I run this line:

pacewalk-setup-postgresql create --db spacewalk --user dbadmin --password 
password --address *

And this is the error that comes up. I ran through the install instructions 
twice  and gotten the same error both times.

Redirecting to /bin/systemctl start postgresql.service
createdb: database creation failed: ERROR:  new encoding (UTF8) is incompatible 
with the encoding of the template database (SQL_ASCII)
HINT:  Use the same encoding as in the template database, or use template0 as 
template.

What do I need to do to get past this error?

FW
_______________________________________________
Spacewalk-list mailing list
Spacewalk-list@redhat.com
https://www.redhat.com/mailman/listinfo/spacewalk-list

Reply via email to