I have two CentOS 6 systems, both are identical and running samer Linux and 
kernel version and they have identical rpms installed.

I have CentOS 6 channels and Errata by mapped by https://cefs.steve-meier.de/ 
script. when I try to update the packages for one systems from systems tab, 
upgrade works fine, the same works fine when I try to update Errata.

When I try to update two systems at the same time using SSM (system set 
manager), the upgrade failed when I try to upgrade packages but works well when 
I try to update Errata. the package upgrade fails because the system tries to 
upgrade packages that doesn't exists.

Packages upgrade works fine when I remove all Errata inforamtion from the 
channel.

for Example:

The SSM tries to upgrade package (samba-winbind-devel-3.6.23-45.el6_9:0-x86_64) 
which is installed on the system. it fails:

Client execution returned "Failed: packages requested raised dependency 
problems: [u'samba-winbind-clients-3.6.23-45.el6_9.i686 requires samba-winbind 
= 3.6.23-45.el6_9']" (code 18)

But I don't have samba-winbind-clients-3.6.23-45.el6_9.i686 installed, and I 
noticed both are part of:

  Errata Update: CL-CESA-2017:2789-1 - Moderate CentOS samba Security Update 
scheduled by samer.odeh  2/14/18 10:09:00 AM CET  2  0  0  2
  samba-winbind-devel-3.6.23-45.el6_9:0-i686
  samba-winbind-devel-3.6.23-45.el6_9:0-x86_64

Only when Errata infromation exists in the channel, the error occurs with SSM 
package upgrade, and it works only with Errata update.

Thanks in advance

_______________________________________________
Spacewalk-list mailing list
Spacewalk-list@redhat.com
https://www.redhat.com/mailman/listinfo/spacewalk-list

Reply via email to