> 
> On Fri, 2017-01-13 at 06:09 -0500, Frediano Ziglio wrote:
> > > 
> > > It works only with glib2 >= 2.32
> > > ---
> > >  configure.ac | 3 +++
> > >  1 file changed, 3 insertions(+)
> > > 
> > > diff --git a/configure.ac b/configure.ac
> > > index a78b4ece..50135b5e 100644
> > > --- a/configure.ac
> > > +++ b/configure.ac
> > > @@ -147,7 +147,10 @@ PKG_CHECK_MODULES([SPICE_PROTOCOL], [spice-
> > > protocol >=
> > > $SPICE_PROTOCOL_MIN_VER])
> > >  AC_SUBST([SPICE_PROTOCOL_MIN_VER])
> > >  
> > >  GLIB2_REQUIRED=2.28
> > > +GLIB2_ENCODED_VERSION="GLIB_VERSION_2_28"
> > >  PKG_CHECK_MODULES([GLIB2], [glib-2.0 >= $GLIB2_REQUIRED gio-2.0
> > > >=
> > >  $GLIB2_REQUIRED])
> > > +GLIB2_CFLAGS="$GLIB2_CFLAGS
> > > -DGLIB_VERSION_MIN_REQUIRED=$GLIB2_ENCODED_VERSION \
> > > +  -DGLIB_VERSION_MAX_ALLOWED=$GLIB2_ENCODED_VERSION"
> > >  AS_VAR_APPEND([SPICE_REQUIRES], [" glib-2.0 >= $GLIB2_REQUIRED
> > > gio-2.0 >=
> > >  $GLIB2_REQUIRED"])
> > >  
> > >  PKG_CHECK_MODULES([GOBJECT2], [gobject-2.0 >= $GLIB2_REQUIRED])
> > 
> > Works on both rhel6 and Fedora 25 however the check is for 2.28
> > while
> > the comment refers to 2.32.
> 
> Because macros using these defines where introduced in Glib 2.32.
> Spice still requires the 2.28 (the latest available in el6)
> 
> With GLib < 2.32 it does nothing - eg if you have glib 2.30 on your
> system and use a function from it, you will not get the warning.
> 
> Pavel
> 

I think my confusion came from reading "It works only with glib2 >= 2.32"
as "spice-server works only with glib2 >= 2.32" while it was
"This check works only with glib2 >= 2.32"

Frediano
_______________________________________________
Spice-devel mailing list
Spice-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/spice-devel

Reply via email to