Bonjour

C'est la première fois que je poste sur cette liste (vieille utilisatrice de Spip essayant de partager son expérience dans différents réseaux je n'ai malheureusement pas le niveau en PHP --simple bidouilleuse autodidacte-- pour être utile ici).

J'aurais besoin d'aide pour essayer d'adapter une contrib qui fonctionne bien en 1.8 et pas en 1.9 Il s'agit d'un devis en ligne que j'aimerais bien utiliser pour un projet dans le monde de l'économie solidaire.

=> La contrib :
<http://www.spip-contrib.net/Proposer-un-devis-en-ligne?var_recherche=devis>

=> Le script qui bloque ("bdc.html"), pour pas alourdir ce message, je l'ai mis en ligne ici :
<http://froure.marsnet.org/bdc.txt>

=> Le message d'erreur dans "spip.php?page=bdc" :

<BOUCLE_bouteilles_valides>(articles)
Erreur MySQL
articles.id_article, articles.titre, articles.surtitre, articles.descriptif, articles.soustitre, articles.chapo, articles.lang FROM spip_articles AS `articles` WHERE (articles.id_article REGEXP '') AND (articles.statut = "publie")
Got error 'empty (sub)expression' from regexp
</BOUCLE_bouteilles_validees>


J'ai l'intuition, mais ce n'est qu'une intuition, que le compilo de Spip 1.9 n'arrive pas à interpréter ces 2 lignes de "bdc.html" (alors que ça passait avec spip 1.8) :

<!-- #ENV{mes_ids,' '})$}>
$_GET['mes_ids'] ='^('. $str.')$';

Ce qu'a l'air de confirmer l'auteur de la contrib dans sa réponse à ma question dans le forum de l'article.

J'espère que ça inspirera quelques un(e)s d'entre vous et que nous arrivions à mettre à jour cette contrib ;-)

Cordialement

Françoise


Répondre à