Hello,
je crois au contraire que Franck a tout à fait raison :
quand tu changes l’intervalle de compatibilité comme ça, en supprimant la 
compat sur une version majeure il faut brancher et incrémenter la version de 
ton plugin d’une version majeure également.

Si on a une faille de sécu qu’on veut corriger sur les versions 3.x de 
formidable, on ne peut faire que du fix partiel qui sera pas déployable sur les 
anciennes versions.
Et a contrario, si tu veux installer un SPIP 3.0 avec une version compatible de 
formidable, tu es mort, il faut faire de l’archéologie pour retrouver la 
derniere version compatible

Et stop avec l’argument  "SPIP 3.0 est plus supporté, la mise à jour c’est 
facile…"
C’est trop facile, totalement coupé de la réalité, et c’est présumer de ce que 
l’utilisateur veut/doit faire, on a pas le droit de flinguer comme ça des 
supports de version :
si je récupère un site en SPIP 3.0 avec une base en SPIP 3.0 et du code proprio 
en SPIP 3.0 et que je dois déjà le faire remarcher à l’identique avant de le 
faire évoluer je suis dans une grosse mouise…

--
Cédric
Le 12 janv. 2020 à 23:32 +0100, Maïeul <mai...@maieul.net>, a écrit :
> de deux choses l'une
> 1. Soit les gens sont sous spip 3.0.0 et ont déjà formidable installé,
> et dans ce cas ils sont juste coincé dans les futures évolutions
> 2. Soit les gens sont sous SPIP 3.0.0 et veulent installer formidable,
> et dans ce cas ils sont poussés à passer à spip 3.1.0 ce qui
> a) n'est pas compliqué
> b) est conseillé en terme de sécurité
>
> Si créer des branches lors d'une rupture de version pour une version de
> spip encore maintenue a du sens, ce n'est pas la même chose pour des
> versions non maintenu
>
> au pire on pose un tags, mais pas une branche en tant que tel (qui
> suppose la possibilité d'évolution future sur cette branche)
> Le 12/01/2020 à 19:45, Franck a écrit :
> > Hello 😊
> > Je pense que le mieux aurait été de faire une branche supportant spip 3.0 
> > et que le trunk soit avec les bornes comme tu viens de faire, car 
> > maintenant ceux qui sont encore en spip 3.0 ne peuvent avoir que la version 
> > 2.5.11 comme version max alors que d'autres sont sans possible avec une 
> > version du plug en 3.x.x
> > C'est pour ça que quand il y a changement de borne de compatibilité, je 
> > pense que le mieux est toujours de faire une branche, même s'il n'y a pas 
> > de changement de "x" concernant la version (même si c'est toujours mieux).
> > Après à voir, cela se discute
>
> _______________________________________________
> liste: https://listes.rezo.net/mailman/listinfo/spip-dev
> doc: https://www.spip.net/
> dev: https://core.spip.net/
> irc://irc.freenode.net/spip
_______________________________________________
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Répondre à