Salut,

Le 16/02/2021 à 12:08, Bruno Bergot a écrit :

Je voulais savoir si vous aviez des retours sur l'utilisation d'un php 7.3 ou 7.4 ?
[…]
Seule la version 3.3 de SPIP sera compatible avec PHP > 7.2, tu peux tenter une 3.2 en PHP 7.3, mais c'est à tes risques et périls (ça peut passer moyennant quelques warnings).

Pour information, Buster (la version stable de Debian publiée il y a une paire d’année) est fournie avec PHP 7.3. Elle propose SPIP 3.2.4 (avec correctifs de sécurité), avec l’intégration d’un correctif à #4205 (qui posait problème lors de la mise à jour de plugins) depuis fin 2019.

Je n’ai pas eu de remontée de problème spécifique à PHP 7.3 (à part celui déjà cité, mais qui ne concerne pas la version 3.2 de SPIP actuelle). Les journaux ne sont pas jolis (warnings, you’ve been warned…).

Bullseye (la prochaine version stable de Debian) fournira PHP 7.4. Elle proposera SPIP 3.2.9 (fingers crossed, early testing welcome…).

Amicalement

David

_______________________________________________
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Répondre à