Bonjour,

Comme nous en discutions l https://www.mail-archive.com/spip-dev@rezo.net/msg71162.html puis là https://www.mail-archive.com/spip-dev@rezo.net/msg71253.html , nous allons tenter de modifier notre cycle de release et la version de PHP avec lequel SPIP  est compatible.

À partir de la version 3.3 à venir, SPIP sera compatible avec les versions PHP maintenues au moment de la sortie de la version SPIP (cela concerne les nouvelles versions majeures x.0.0 ou x.y.0 seulement).

SPIP 3.3 nécessitera donc compatible de PHP 7.3 à 8.0 (enfin si on la sort avant décembre ! 😁)

Concernant SPIP 3.2, nous sortirons prochainement une version qui va améliorer le support jusqu'à PHP 7.4, en corrigeant des «deprecated» et diverses petites choses qui ne sont pas actuellement bloquantes, mais qui vont alléger un peu les log des serveurs.

SPIP 3.2 sera donc compatible de PHP 5.4 à 7.4

MM.


_______________________________________________
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Répondre à