Bonjour,

Cela produit cette erreur : Parse error: syntax error, unexpected '[' in /home/fondssai/www/plugins/auto/saisies/v3.23.0/saisies_fonctions.php on line 134

Et cette ligne contient
if (!in_array($type_saisie, ['hidden','fieldset'])) {

La doc de php indique effectivement
https://www.php.net/manual/fr/language.types.array.php
<?php
$array = array(
    "foo" => "bar",
    "bar" => "foo",
);

// depuis PHP 5.4
$array = [
    "foo" => "bar",
    "bar" => "foo",
];
?>

Faut-il corriger ?
Ou mettre un necessite PHP 5.4 ?

--
RealET

----
spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone

Répondre à