Le 20/07/2019 à 11:05, RealET a écrit :
Bonjour,

Cela produit cette erreur : Parse error: syntax error, unexpected '[' in /home/fondssai/www/plugins/auto/saisies/v3.23.0/saisies_fonctions.php on line 134

Et cette ligne contient
if (!in_array($type_saisie, ['hidden','fieldset'])) {

La doc de php indique effectivement
https://www.php.net/manual/fr/language.types.array.php
<?php
$array = array(
     "foo" => "bar",
     "bar" => "foo",
);

// depuis PHP 5.4
$array = [
     "foo" => "bar",
     "bar" => "foo",
];
?>

Faut-il corriger ?
Ou mettre un necessite PHP 5.4 ?

dans la mesure où les versions de spip maintenu autorisent encore php 5.3 (même si je trouve pas ca une très bonne idée), et que saisie est un plugin assez répandu, je corrige.

(et franchement, vivement le jour où on ferai que du php 7.xxx, il y a des tels raccourcis...)

----
spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone

Répondre à