Yop 😊

Bon alors avec un peu de retard, j’ai même demander à eric sur l’irc car tu me 
faisais avoir un doute même si ton cas aurait été unique sur la zone 😃

Bref, juste pour dire que non faut mettre les mêmes bornes de compatibilité 
dans paquet et plugin.xml car il s’agit du même plug !

Normalement, devrait pas y avoir de problèmes !

Franck

 

 

De : cam.la...@azerttyu.net <cam.la...@azerttyu.net> 
Envoyé : jeudi 5 septembre 2019 12:13
À : Franck <spip.fra...@lien-d-amis.net>
Cc : spip-zone <spip-zone@rezo.net>; spip <goldst...@rezo.net>
Objet : Re: [Spip-zone-commit] r117714 
-_plugins_/ckeditor-spip-plugin/branches/ckeditor-4.x

 

Bonjour

 

Le mar. 3 sept. 2019 à 17:59, Franck <spip.fra...@lien-d-amis.net 
<mailto:spip.fra...@lien-d-amis.net> > a écrit :

Hello 😊
Pourquoi ne pas le mettre dans le dossier "lib" de la zone ?
https://zone.spip.net/trac/spip-zone/browser/spip-zone/_libs_

 

Car la zone n'est pas là pour héberger de l'archive. Subversion n'est pas fan 
et encore moins trac à jouer le role de proxy pour des zip.

J'aurais préféré mettre ceci sur files.spip.net <http://files.spip.net>  mais à 
priori ce n'est pas possible donc j'ai basculé sur contrib.

Si meilleure solution je prends.

 

En soit https://zone.spip.net/trac/spip-zone/browser/spip-zone/_libs_ me semble 
une très mauvaise pratique.

 

Sinon, je ne sais pas si tu fais bien de mettre 2.1.30 comme version mini de 
spip et non pas 3.2 pour le sad ...

 

Pas de sad :)

 

En tout cas, si tu tiens vraiment à mettre 2.1.30 comme version mini, faut que 
tu fasses des modifications dans paquets et plugin.xml
Dans paquet.xml, il faudrait mettre :

https://zone.spip.net/trac/spip-zone/browser/spip-zone/_plugins_/ckeditor-spip-plugin/branches/ckeditor-4.x/paquet.xml#L6
compatibilite="[2.1.30;3.2.*]"

et dans plugin.xml
https://zone.spip.net/trac/spip-zone/browser/spip-zone/_plugins_/ckeditor-spip-plugin/branches/ckeditor-4.x/plugin.xml#L97
<necessite id="SPIP" version="[2.1.30;3.2.99]" />

 

C'est bien volontaire. On a un traitement bien distinct entre les 2 fichiers. 
plugin.xml ne peut fonctionner qu'avec spip2 tandis que paquet.xml uniquement 
avec spip3.

Leur intervalle est donc resteint à leur cas d'usage.

Il y a des contraintes de surcharge de squelettes dont jquery pour spip2 qu'on 
ne doit en aucun voir dans spip3. Le blocage au niveau des version garanti que 
cela ne se produira jamais.

 

Possible que je me sois planté dans la logique :)

 

Km

----
spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone

Répondre à