Tout à l'heure sur IRC, ça évoquait SPIP 3.3, et la nécessité de commencer à changer les bornes de compatibilité des plugins.

Ça m'a fait penser que pour le passage de SPIP 3.0 à SPIP 3.1, on avait rédigé un article complet qui expliquait comment migrer un plugin entre ces 2 versions : https://contrib.spip.net/article4580 Oui car il ne suffit pas de changer la borne, parfois il y a d'autres choses à faire dû aux montées de versions de jQuery, etc.

Pour les autres versions de SPIP, en général les informations sont trouvent disséminées dans les articles de doc générale : https://www.spip.net/article6399 etc.

Je pense qu'il faudrait un article dédié aux plugins pour chaque montée de version, qui réponde simplement à la question : que faut-il faire pour s'assurer qu'un plugin continue de fonctionner avec la version n+1 de SPIP ?
Et il faudrait tous les regrouper au même endroit.

Naturellement, l'endroit le plus approprié me semble être programmer, du coup j'ai commencé la rédaction de plusieurs articles à partir de SPIP 3 (en cours de rédac, seuls les admins peuvent les voir pour l'instant) :
* https://programmer.spip.net/ecrire/?exec=article&id_article=971
* https://programmer.spip.net/ecrire/?exec=article&id_article=972
* https://programmer.spip.net/ecrire/?exec=article&id_article=973

Par contre pour celui existant sur contrib, je ne vois pas quoi faire.
Le recopier sur programmer ok, mais ensuite que faire de celui de contrib ?
Une redirection ? Un lien dans le texte de l'article vers celui de programmer ? Autre chose ?

----
spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone

Répondre à