Le mardi 24 septembre 2019 à 09:51 +0200, Cerdic a écrit :
> AAAAAAAAARRRRRRRRGGGGGGGGHHHHHHHHHH
> include_spip(‘plugins/installer’);
> dans un fichier _options.php
> SERIEUSEMENT ?
> 
> Je rappelle que les fichiers _options.php sont appelés à CHAQUE hit
> d’un page. Réflechissez toujours à deux fois avant de faire un truc
> dedans.
> Et spip_version_compare() c’est super lourd pour ce genre de test,
> c’est pas pour rien qu’on l’a mis dans plugins/xxx, c’est vraiment
> pour gérer les problématiques de numéro de version inconsistants,
> divers, et avec jokers.
> 
> Quelque chose du genre
> $version = explode(‘.’,$GLOBALS[‘spip_version_branche’]);
> if (array_shift($version)>3 or array_shift($version)>=2) {
> ..
> }
> fait le job beaucoup plus simplement et rapidement
> 

hum. Je comprend ton souci de performance. Mais de là a dire que cela
fait le job plus simplement. C'est pas franchement un test hyper clair
:-). Bref, je viens de commiter les corrections

----
spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone

Répondre à