Hello Jean Marie,

ça se passe dans la fonction  newsletter_fixer_image() du fichier 
newsletter_fonctions.php
Tu peux essayer d’enlever l’ancre #fixed ou le timestamp voire de raccourcir le 
hash md5 et voire ce qui coince ?

En fonction de ça j’essayerai de trouver un patch qui marche sans rien casser à 
côté


--
Cédric
Le 13 nov. 2019 à 17:11 +0100, Jean Marie Grall 
<jeanmarie.lis...@cousumain.info>, a écrit :
> Salut,
>
> après pas mal de tests, j'ai l'impression que les images des newsletters
> ne s'affichent pas dans le webmail Yahoo.
>
> J'ai voulu tester la longueur des URL ou l'arborescence type /IMG/nl/16/
> ou encore la présence du timstamp (bref, des urls trop complexes) mais
> je suis coincé car, même si je modifie le code figé (écrit en dur) pour
> raccourcir les urls, elles sont réécrites à l'envoi avec la forme
> /IMG/nl/xx/xxxxxxxxxxxx.png?123456
>
> Est-ce que quelqu'un reproduit le problème ?
>
> Par contre, si j'utilise le plugin image_responsive, les images
> s'affichent bien. Elles ont une url type /IMG/jpg/a231-resp160.jpg qui
> fonctionnent avec de l'url_rewriting pour actionner un script php :
> https://zone.spip.org/trac/spip-zone/browser/spip-zone/_plugins_/image_responsive/ajouter_a_htaccess.txt
>
> Voilà pour les infos que j'ai réussi à réunir.
>
> Ma config : SPIP 3.2 + trio Newsletter/Mailshot/Mailsubscriber à jour.
> Envoi via SMTP OVH et Mailjet.
>
>                     jean marie
>
> ----
> spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone
----
spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone

Répondre à