Hop,

Le 19/11/2019 à 19:48, RastaPopoulos a écrit :
Le 19/11/2019 à 16:34, Bruno Bergot a écrit :
Non, je pense qu'il est plus sympa pour les users de laisser le plugin existant 
tel quel, donc :

si on lui demande explicitement de ne pas le faire, il n'insère rien

Moi je pense l'inverse. :)


Moi je tente de penser en tant qu'utilisateur *actuel* du plugin (puisque je ne l'utilise pas ^^).

Si on fait une nouvelle version majeure :
- le plugin ne fournit déjà quasiment que la lib, il n'y a presque pas de code 
en plus à part l'appel
- il est uniquement destiné à des dévs intégration, et il ne fait absolument 
rien tout seul, il demande de toute façon que les gens codent des choses 
précises dans leurs squelettes

"devs intégrations" qui ont peut-être "livré" le plugin à des personnes qui ne sont que des admins de sites.

- donc ça ne gène pas des masses que lors d'un saut de version majeure, on leur 
demande juste comme mini modif de penser à activer l'insertion de la lib

Ça me chagrine toujours de voir un comportement changer comme ça, même si la "justification" du changement de version majeure indique que "ça va casser des trucs existants".

- cela permet par contre de faire en sorte que le plugin soit réellement 
générique et puisse être utilisé uniquement pour nécessiter la lib ; alors que 
sinon, c'est aux gens de penser à le désactiver pour ne pas se la trimbaler 
partout


À qui imposer ce changement ? Aux admins des sites ou aux gens qui souhaitent utiliser le plugin en tant que lib uniquement (des devs donc) ?

Mais bon, je ne pense pas que ça soit bien important quelle que soit la décision, le plugin est utilisé sur 54 sites d'après https://plugins.spip.net/tablesorter :p

++
b_b
----
spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone

Répondre à