Bonjour,
Le 23/11/2019 à 21:45, Stephane Santon a écrit :
Super ! Cette solution a résolu mon pb de
https://www.mail-archive.com/spip-zone@rezo.net/msg48588.html

Y a-t-il moyen de charger un spip 3.2 dev par spip_loader ?

Faute de réponse, j'ai modifié Spip_loader en remplaçant 3.2 par dev *en comptant obtenir les dernières maj (non publiées) de 3.2.*

Donc dans l'interface j'ai sélectionné dev.

Mais j'ai récupéré une 3.3.0 dev !! Donc site un peu cassé. (j'utilise un Zpip-dist V1)

1. Comment demander donc à Spip_loader la dernière svn d'une branche ? Peut-être un travail sur l'interface de spip_loader à faire, qui au moins afficherait ici que la "dev" est une 3.3.0 et non la svn de la branche présente.

2. J'ai maintenant un message
"Compatibilité forcée
Les plugins compatibles avec SPIP 3.2.99 peuvent être activés."

Qu'est-ce que ça veut dire ??
- "C'est forcé -> c'est possible qu'ils soient actuellement activés"
- "A propos du forçage -> je peux les activer" -> mais comment ? pas de lien, pas d'info
- ...

?

Merci


Le 21/11/2019 à 16:51, Jean Marie Grall a écrit :
Suite à un échange avec b_b, la solution qui fonctionne chez moi :
- installer le plugin
- attendre plus de 2s
- faire une réparation de la base (menu Maintenance > Maintenance technique)

L'idée (confirmer) est qu'à l'installation du plugin, le cache PHP opcache (cache de 2s chez moi) empêche SPIP d'avoir les bons scripts avec les instructions de création des tables. Donc, en réparant la base, on relance les scripts d'installation mais, entre temps, le cache a été vidé et on a la nouvelle version des scripts.

Indice qui va dans ce sens : à l'installation, avec define('_LOG_FILTRE_GRAVITE', 8);, il n'y a pas d'erreurs mysql alors que les tables ne sont pas créées.

V'là, merci pour la fourberie ;)



--
Stéphane

Les Voisins Spipeurs : http://www.voisins-spipeurs.net
----
spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone

Répondre à