Bonsoir,

Merci pour toutes ces réponses.

Le 02/12/2019 à 21:28, Franck a écrit :
Alors si pour info spip_loader permet d'avoir la 3.2_dev, il suffit de 
remplacer la ligne:
https://zone.spip.org/trac/spip-zone/browser/spip-zone/_outils_/spip_loader/trunk/spip_loader.php#L50
par:
'zip' => 'spip/dev/SPIP-branche-3.2.zip',

Mais attention, car j'avais trouver un problème à une époque et je n'ai pas 
prit le temps, de refaire des essais pour voir si le problème est toujours 
présent, donc attention...
https://core.spip.net/issues/4158

Dommage qu'il manque sur spip_loader cette fonctionnalité qui paraît basique !

Sinon concernant le message: "Les plugins compatibles avec SPIP 3.2.99 peuvent être 
activés"
C'est normal, cela vient du fait que tu as installer spip 3.3 et comme cette version 
n'est pas encore dispo, il y a un dispositif permettant quand même de faire fonctionner 
les plugins qui sont normalement pour spip 3.2 max. Cela permet de faire des tests aux 
plugins avant la sortie de spip 3.3 et ainsi donne "un peu" plus de temps aux 
auteurs pour faire des corrections si besoin, et ainsi de les mettre compatible spip 3.3 
dès qu'il sortira.
En plus cela a comme avantage, de permettre de voir dans le cas d'un bug, si 
cela vient du plug ou de spip. 😊

OK pour l'explication.
Donc l'info serait plus claire avec qqchose su genre :
"Les plugins définis pour SPIP 3.2.99 ont été temporairement rendus compatibles avec cette version dev"

Franck

Bonne soirée

-----Message d'origine-----
De : Stephane Santon <m.spipr...@santonum.eu>
Envoyé : samedi 30 novembre 2019 18:43
À : spip-zone@rezo.net
Objet : Re: [SPIP Zone] Tables non créées à l'installation d'un plugin

Bonjour,
Le 23/11/2019 à 21:45, Stephane Santon a écrit :
Super ! Cette solution a résolu mon pb de
https://www.mail-archive.com/spip-zone@rezo.net/msg48588.html

Y a-t-il moyen de charger un spip 3.2 dev par spip_loader ?

Faute de réponse, j'ai modifié Spip_loader en remplaçant 3.2 par dev *en 
comptant obtenir les dernières maj (non publiées) de 3.2.*

Donc dans l'interface j'ai sélectionné dev.

Mais j'ai récupéré une 3.3.0 dev !! Donc site un peu cassé. (j'utilise un 
Zpip-dist V1)

1. Comment demander donc à Spip_loader la dernière svn d'une branche ?
Peut-être un travail sur l'interface de spip_loader à faire, qui au moins afficherait ici 
que la "dev" est une 3.3.0 et non la svn de la branche présente.

2. J'ai maintenant un message
"Compatibilité forcée
Les plugins compatibles avec SPIP 3.2.99 peuvent être activés."

Qu'est-ce que ça veut dire ??
- "C'est forcé -> c'est possible qu'ils soient actuellement activés"
- "A propos du forçage -> je peux les activer" -> mais comment ? pas de lien, 
pas d'info
- ...

?

Merci


Le 21/11/2019 à 16:51, Jean Marie Grall a écrit :
Suite à un échange avec b_b, la solution qui fonctionne chez moi :
- installer le plugin
- attendre plus de 2s
- faire une réparation de la base (menu Maintenance > Maintenance
technique)

L'idée (confirmer) est qu'à l'installation du plugin, le cache PHP
opcache (cache de 2s chez moi) empêche SPIP d'avoir les bons scripts
avec les instructions de création des tables. Donc, en réparant la
base, on relance les scripts d'installation mais, entre temps, le
cache a été vidé et on a la nouvelle version des scripts.

Indice qui va dans ce sens : à l'installation, avec
define('_LOG_FILTRE_GRAVITE', 8);, il n'y a pas d'erreurs mysql alors
que les tables ne sont pas créées.

V'là, merci pour la fourberie ;)



--
Stéphane

Les Voisins Spipeurs : http://www.voisins-spipeurs.net
----
spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone




--
Stéphane

Les Voisins Spipeurs : http://www.voisins-spipeurs.net
----
spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone

Répondre à