Hi guys, thanks for reading this! I’m new so sorry if this is a dumb question! 
But I've been finding the answer for 3 days but still no sign of light.

I’ve already posted the problem on GCE discussion group- this link: 

To make it clear, I also restate the problem here:
Been working on this for 2 days and still cannot find the way out :(

Below is my setup for testing, which basically supports all http_access through 
port 8888

-squid.conf file:

http_port 8888
http_access allow all
-Open port 8888 for incoming HTTP data by gcloud command (which returned 

gcloud compute firewall-rules create allow-tcp --description 
"Incoming-http-allowed." --allow tcp:8888 --format json
With the setup above, I can telnet to the IP with port 8888. However, when 
querying to some http links with browser (Safari/Chrome), I always get this 

The following error was encountered while trying to retrieve the URL: 
http://google.com/ <http://google.com/>

Access Denied.

Access control configuration prevents your request from being allowed at this 
time. Please contact your service provider if you feel this is incorrect.

Your cache administrator is webmaster.
I also tried other ports (3128, 8000, 80) but no help
I also tried to force the port to listen IPv4 addresses with something like 
http_port <> and still not working
Someone please help me out of this mess :( Much appreciated!

P/S: I connect to the squid proxy though my Macbook (OS Sierra) with Web Proxy 
(HTTP) enabled in Network Preferences.

This is some logs from cache.log, which probably indicates that my conf file is 
fraud. client_side.cc(777) swanSong: local=10.xxx.0.2:8888 
remote=113.xxx.xxx.113:54856 flags=1 - 10.xxx.0.2 is GCE's internal IP - 
113.xxx.xxx.113 is my computer's external IP 

Much appreciated if anyone can help me out!

Thank you!
squid-users mailing list

Reply via email to