Thanks for the testing and feedback. I've applied this as part-2 of the
bug 4302 updates. It will be in the next releases of 3.5 and 4.x.


One more patch for Intercept.cc:

On NetBSD, USE_INET6 is only defined by netinet/ip_compat.h if
__NetBSD_Version__ is defined by sys/param.h:

#if defined(__NetBSD_Version__) && (__NetBSD_Version__ >= 105000000) && \
    !defined(_KERNEL) && !defined(USE_INET6) && !defined(NOINET6)
# define        USE_INET6
#endif

So we have to include sys/param.h:


--- Intercept.cc        2016-10-13 16:24:31.000000000 +0200
+++ Intercept.cc.orig   2016-10-13 16:20:37.000000000 +0200
@@ -25,6 +25,9 @@
 #define IPFILTER_VERSION        5000004
 #endif

+#if HAVE_SYS_PARAM_H
+#include <sys/param.h>
+#endif
 #if HAVE_SYS_IOCCOM_H
 #include <sys/ioccom.h>
 #endif

Thank you!
--
Gergely EGERVARY

_______________________________________________
squid-users mailing list
squid-users@lists.squid-cache.org
http://lists.squid-cache.org/listinfo/squid-users

Reply via email to