Maybe it’s due to errors in config (as syslog tells me), but according to doc, 
there is no errors

app_lua_run_ex(): error from Lua: /etc/kamailio/lua/kamailio.lua:394: attempt 
to call field 'has_body' (a nil value)

but
...
if (KSR.textops.has_body()) then
…

and module textops.so is loaded.

Regards, Igor

On Mar 13, 2018, 4:05 PM +0200, Igor Olhovskiy <igorolhovs...@gmail.com>, wrote:
> Kamailio version is kamailio 5.1.0-dev6
>
> Regards, Igor
>
> On Mar 13, 2018, 4:03 PM +0200, Igor Olhovskiy <igorolhovs...@gmail.com>, 
> wrote:
> > Hi!
> >
> > I’m playing with new KEMI framework and trying to reload script without 
> > reloading Kamailio.
> >
> > Lua code is mostly one from example.
> >
> > ...
> > modparam("app_lua", "load", "/etc/kamailio/lua/kamailio.lua")
> > cfgengine "lua"
> > ...
> >
> > So, I’m changing lua code and giving command
> >
> > kamctl rpc app_lua.reload
> >
> > But in the answer
> >
> > {
> >   "jsonrpc":  "2.0",
> >   "error":  {
> >     "code": -32000,
> >     "message":  "Execution Error"
> >   },
> >   "id": 11098
> > }
> >
> > In syslog there is a string
> >
> > /usr/sbin/kamailio[10939]: ERROR: app_lua [app_lua_api.c:399]: 
> > lua_sr_reload_script(): reload is not activated
> >
> >
> > What is need to be done to activate reload?
> >
> >
> > Regards, Igor
_______________________________________________
Kamailio (SER) - Users Mailing List
sr-users@lists.kamailio.org
https://lists.kamailio.org/cgi-bin/mailman/listinfo/sr-users

Reply via email to