El mié., 4 de sep. de 2019 a la(s) 02:03, Aristeidis Tsitras (
tsit...@gmail.com) escribió:

>  when i have the adsl attached on the network then on the pcap file i see
> the public IP of the router something like 2200@62.38.100.150 instead of
> 2200@192.168.1.7. When i unplug the adsl from the router, then i get
> 2200@192.168.1.7. This happens only for the windows PC.
>

seems pretty clear the problem -> " This happens only for the windows PC."

that M$ thing have their own routing problems.. so makes sense that if
router do not have public address the routing stsart to works in some
manner, same procedure happened if yu plug or unplug.. that sh** said in
the network icon "there's no network interenet connection" with a
exclamation icon... but network are still present, so use a real os


> Also there was an attempt from a second windows PC in the network to
> register, but i could not see anything coming through. It is the extension
> 2202 and the IP is 192.168.1.8
>
>
> I would appreciate any help available, please.
>
>
>
> Στις Παρ, 30 Αυγ 2019 στις 4:09 μ.μ., ο/η David Villasmil <
> david.villasmil.w...@gmail.com> έγραψε:
>
>> Log into asterisk’s cli and see what it has to say.
>>
>> On Fri, 30 Aug 2019 at 14:07, Aristeidis Tsitras <tsit...@gmail.com>
>> wrote:
>>
>>> attached you can find the pcap.
>>> IPs
>>>
>>>    - 192.168.1.220. Kamailio at port 5060 and Asterisk at port 5080
>>>    - 192.168.1.7.    Zoiper softphone in Windows PC. extension 2200
>>>    - 192.168.1.124. Softphone in Android phone. extension 2201
>>>
>>> 2200 calls 2201. 2200's softphone says call established, probably
>>> voicemail, but 2201 never receives the call.
>>>
>>> Thanks in advance for your help
>>>
>>>
>>> Στις Παρ, 30 Αυγ 2019 στις 2:19 μ.μ., ο/η David Villasmil <
>>> david.villasmil.w...@gmail.com> έγραψε:
>>>
>>>> The users are registered on kamailio, not asterisk, that’s why you
>>>> don’t see them in asterisk.
>>>>
>>>> The voicemail is happening because asterisk doesn’t know where the user
>>>> being called is. So I assume kamailio is not forwarding the registration
>>>> location to asterisk.
>>>>
>>>> Make a trace with I.e.: sngrep while registering, you should the
>>>> register forward happening.
>>>>
>>>> On Fri, 30 Aug 2019 at 09:55, Aristeidis Tsitras <tsit...@gmail.com>
>>>> wrote:
>>>>
>>>>> new to the area and trying to setup Kamailio with Asterisk in a single
>>>>> machine. All users will register to Kamailio's port and in case of need 
>>>>> for
>>>>> media, it will be forwarded to Asterisk, that is my intention. All of my
>>>>> work is based on the following link
>>>>> https://kb.asipto.com/asterisk:realtime:kamailio-4.0.x-asterisk-11.3.0-astdb.
>>>>> Here is what i have done:
>>>>>
>>>>>    - Debian 8, 64 bit machine with mysql and odbc
>>>>>    -
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> *root@kamast: ~ $ lsb_release -a No LSB modules are available.
>>>>>    Distributor ID: Debian Description:    Debian GNU/Linux 8.11 (jessie)
>>>>>    Release:        8.11 Codename:       jessie root@kamast: ~ $ uname -a 
>>>>> Linux
>>>>>    kamast 3.16.0-10-amd64 #1 SMP Debian 3.16.72-1 (2019-08-13) x86_64
>>>>>    GNU/Linux root@kamast: ~ $  *
>>>>>    - Kamailio 5.2 installed from Kamailio's deb repository
>>>>>    - Asterisk 13LTS installed from source
>>>>>    - Used the same passwords such as kamailiorw and
>>>>>    asterisk_password, since this is a test system, for proof of concept.
>>>>>
>>>>> I did import to the mysql>asterisk database 3 users 2200, 2201 and
>>>>> 2202. Then created in sip.conf the same 3 users with the same credentials.
>>>>> Then on 3 PCs i used softphones (Jitsi, Zoiper) and registered each 
>>>>> account
>>>>> to a softphone. Problems:
>>>>>
>>>>>    - Cannot see the users in the Asterisk's cli, sip show peers
>>>>>    - I can see users only in Kamailio with kamctl ul show
>>>>>    - A call between the extensions goes to voicemail. It never
>>>>>    reaches the other destination eg 2200 calls 2201 and in Asterisk's 
>>>>> console
>>>>>    i am getting a message that 2201 is absent and it goes to voicemail. 
>>>>> The
>>>>>    same with any other extension.
>>>>>
>>>>> Attached you can find:
>>>>>
>>>>>    1. Kamailio.cfg
>>>>>    2. Asterisk's sip.conf
>>>>>    3. Asterisk's extension.conf
>>>>>    4. The import that i have done to mysql for the user creation.
>>>>>
>>>>>
>>>>> I would appreciate if someone could point me to the error and help me
>>>>> fix it please?
>>>>>
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> Kamailio (SER) - Users Mailing List
>>>>> sr-users@lists.kamailio.org
>>>>> https://lists.kamailio.org/cgi-bin/mailman/listinfo/sr-users
>>>>>
>>>> --
>>>> Regards,
>>>>
>>>> David Villasmil
>>>> email: david.villasmil.w...@gmail.com
>>>> phone: +34669448337
>>>> _______________________________________________
>>>> Kamailio (SER) - Users Mailing List
>>>> sr-users@lists.kamailio.org
>>>> https://lists.kamailio.org/cgi-bin/mailman/listinfo/sr-users
>>>>
>>> _______________________________________________
>>> Kamailio (SER) - Users Mailing List
>>> sr-users@lists.kamailio.org
>>> https://lists.kamailio.org/cgi-bin/mailman/listinfo/sr-users
>>>
>> --
>> Regards,
>>
>> David Villasmil
>> email: david.villasmil.w...@gmail.com
>> phone: +34669448337
>> _______________________________________________
>> Kamailio (SER) - Users Mailing List
>> sr-users@lists.kamailio.org
>> https://lists.kamailio.org/cgi-bin/mailman/listinfo/sr-users
>>
> _______________________________________________
> Kamailio (SER) - Users Mailing List
> sr-users@lists.kamailio.org
> https://lists.kamailio.org/cgi-bin/mailman/listinfo/sr-users
>
_______________________________________________
Kamailio (SER) - Users Mailing List
sr-users@lists.kamailio.org
https://lists.kamailio.org/cgi-bin/mailman/listinfo/sr-users

Reply via email to