On (15/09/16 20:44), Lukas Slebodnik wrote:
>On (15/09/16 14:08), Lukas Slebodnik wrote:
>>On (05/07/16 13:39), Lukas Slebodnik wrote:
>>>ehlo,
>>>
>>>SSSD python packages were renamed in fedora few months ago.
>>> python-* -> python2-*
>>>But we didn't rename packages in upstream spec file and therefore
>>>upgrade from fedora 24 -> sssd master is not possible.
>>>
>>>Attached patch shoudl fix the issue.
>>>
>>>BTW here are provides and obsoletes for current master
>>>  sh$ rpm -qp --provides python-libipa_hbac-1.13.92-0.fc24.x86_64.rpm
>>>  libipa_hbac-python = 1.13.92-0.fc24
>>>  python-libipa_hbac = 1.13.92-0.fc24
>>>  python-libipa_hbac(x86-64) = 1.13.92-0.fc24
>>>
>>>  sh$ rpm -qp --obsoletes python-libipa_hbac-1.13.92-0.fc24.x86_64.rpm
>>>  libipa_hbac-python < 1.12.90
>>>
>>>and after renaming
>>>  sh$ rpm -qp --provides python2-libipa_hbac-1.13.92-0.el6.x86_64.rpm
>>>  libipa_hbac-python = 1.13.92-0.el6
>>>  python-libipa_hbac = 1.13.92-0.el6
>>>  python2-libipa_hbac = 1.13.92-0.el6
>>>  python2-libipa_hbac(x86-64) = 1.13.92-0.el6
>>>
>>>  sh$ rpm -qp --obsoletes python2-libipa_hbac-1.13.92-0.el6.x86_64.rpm
>>>  libipa_hbac-python < 1.12.90
>>>  python-libipa_hbac < 1.13.92-0.el6
>>>
>>
>>Attached is an updated patch.
>>
>>http://sssd-ci.duckdns.org/logs-test/job/4/51/summary.html
>>
>I sent wrong patch in previous mail.
>
>LS

>From 60f504d1123a3458a85797b7063cfee8202e5cf4 Mon Sep 17 00:00:00 2001
>From: Lukas Slebodnik <lsleb...@redhat.com>
>Date: Wed, 14 Sep 2016 14:31:29 +0200
>Subject: [PATCH] SPEC: Rename python packages using macro %python_provide
>
>Fedora and epel contains macro %python_provide
>for simpler renaming of python packages. It will generate correct
>provides and obsoletes.
Bump

LS
_______________________________________________
sssd-devel mailing list -- sssd-devel@lists.fedorahosted.org
To unsubscribe send an email to sssd-devel-le...@lists.fedorahosted.org

Reply via email to