Tim Adams-2 wrote: > > Hi Martin, > > I don't know what is on your 4.2.1 agenda yet, but I thought I'd suggest > that the _RWSTD_* style macros be replaced by _STDCXX_* or something > similar for clarity. Is this already on your list of tasks for 4.2.1? >
I've thought about the names in the past but we haven't discussed renaming them and there is no request in Jira to do so. The names of many of the macros are documented and intended to be used by end users (especially the _RWSTD_NO_EXT_XXX kind which control stdcxx extensions) so we couldn't make such a change in a maintenance release for compatibility reasons (we can't even deprecate them there). I'm not even sure that making it would be in the scope of a minor release. Maybe in 5.0. Speaking for myself, though, I'm not bothered by the _RW prefix in the names. I admit I kind of like it. It's a nice reminder of the heritage of the project. Others might feel differently ;-) If you'd like to see them replaced feel free to file a Jira request. Martin -- View this message in context: http://www.nabble.com/timeframe-for-4.2.1--tf4749764.html#a13596137 Sent from the stdcxx-dev mailing list archive at Nabble.com.