When we added unwinding feature (activated with -k option), we also added a code for caching the entries of /proc/$pid/maps.
The code for caching was tightly integrated with the code for unwinding. However, while prototyping kvm vcpu state dump feature to strace[1], I found the code for caching is useful for other purposes than unwinding feature. This patch set makes the code for caching usable independently of unwinding feature. In the changes, I call the newly separated code for caching "mmap_cache subsystem". [1] https://marc.info/?l=kvm&m=151531408406144&w=2 Masatake YAMATO (8): unwind: lift up unw_flush_cache from mmap cache management code mmap_cache: new subsystem derived from unwind.c mmap_cache: Move code for searching an mmap cache from unwind mmap_cache: record protection bits mmap_cache,unwind: lift up mmap_cache_delete invocation from unwind.c mmap_cache: add function to enable mmap_cache mmap_cache: record device major and minor numbers mmap_cache: add customizable search function Makefile.am | 1 + defs.h | 49 +++++++++++- mmap_cache.c | 253 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ strace.c | 2 + syscall.c | 6 +- unwind.c | 256 ++++++++++------------------------------------------------- 6 files changed, 350 insertions(+), 217 deletions(-) create mode 100644 mmap_cache.c -- 2.14.3 ------------------------------------------------------------------------------ Check out the vibrant tech community on one of the world's most engaging tech sites, Slashdot.org! http://sdm.link/slashdot _______________________________________________ Strace-devel mailing list Strace-devel@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/strace-devel