G'day Tony,

I've just tested with OLPC OS 13.2.10, and this method is working fine
with XO-1.5, XO-1.75, and XO-4.  It does not work properly with XO-1.

The shared or private switch does not block the communication at all,
since the HTTP connection does bypass Telepathy.

Most likely causes of what you describe are;

1.  wireless radio electrostatic discharge damage to one of the
laptops in the room,

2.  break of antenna cable to one of the laptops in the room.

When either of these occur, there can be two ad hoc networks formed
with the same name, but containing different laptops.  This will give
errors in Browse when you try to load the content via port 8000.

Both of these conditions are highly likely as the laptops age; ESD is
cumulative, and the plasticiser evaporates from the cable insulation
making it brittle.

It only takes one laptop in a room to cause this.

A quick test depends on the Network Neighbourhood.  If the other
laptops can be seen, then they do share the same ad hoc network
network.  If they cannot be seen, they might not share the same
network.

Another test is to "ping IP" where IP is the IP address you mentioned
as being shared.  If this does not respond with "64 bytes from ..."
repeatedly, then there is something fundamentally wrong with the ad
hoc wireless network.

It does not work the same way with XO-1 because XO-1 offers IEEE
802.11s mesh channels instead.  XO-1 can join an ad hoc network if one
is already formed by XO-1.5 or later, but cannot form a new one.

With an unlocked laptop you can test the antennas using firmware;
http://wiki.laptop.org/go/Antenna_testing

Should you need a laptop unlocked, send me the serial number.

(removed CC support-gang, as I'm not subscribed.)

On Tue, Dec 03, 2019 at 09:40:41AM +0200, Tony Anderson wrote:
> The dicussion below  appears to refer to the use of an XO to administer a
> schoolserver. I urgently need help at the other end: using an XO toserve
> content in a classroom using 'SimpleHTTPServer'. This is an installed Python
> module that enables an XO to serve content via an ad-hoc network. The
> content is put on a usb pendrive or an sd card. It is mounted on an XO which
> acts as the server. This XO connects to an ad hoc network The system moves
> to the pendrive as the working directory. Note: XO laptops in Rwanda have at
> most 2GB storage.  It issues python -m SimpleHTTPServer. The XO serves
> content on a selected port (by default 8000). The provider notes the url
> shown on the Frame network widget (right-click). This IP adddress is written
> on a blackboard.
> 
> The client XOs connect to the same ad hoc network. They open Browse and
> issue an http request such as http 169.258.9.16:8000 where the address is
> the IP address on the blackboard. The return is a list of files and folders
> in the pendrive root or the index.html page in the root. That page can
> display an index to the content, a subset of the IIAB content (e.g. pdfs
> from Rachel or Sugar activities or Phet simulations). This technique has
> proven very valuable in classrooms that cannot be reached by a router from
> the schoolserver or in schools which do not have a school server. It costs
> only the price of the usb device. An 8gb device provides 4 times the storage
> capacity of the XO.
> 
> My problem is that this no longer works (13.2.9 Sugar 0.112). The server XO
> does not see the http requests from the clients XOs. My suspicion is the
> shared|private switch in private mode blocks the communication over the
> ad-hoc network. It would help lots of students and teachers if this problem
> can be resolved. Perhaps there is a way to enable the network without
> becoming dependent on the collaboration system.
> 
> Tony
> 
> 
> 
> On 02/12/2019 19:00, support-gang-requ...@lists.laptop.org wrote:
> > Send support-gang mailing list submissions to
> >     support-g...@lists.laptop.org
> > 
> > To subscribe or unsubscribe via the World Wide Web, visit
> >     http://lists.laptop.org/listinfo/support-gang
> > or, via email, send a message with subject or body 'help' to
> >     support-gang-requ...@lists.laptop.org
> > 
> > You can reach the person managing the list at
> >     support-gang-ow...@lists.laptop.org
> > 
> > When replying, please edit your Subject line so it is more specific
> > than "Re: Contents of support-gang digest..."
> > 
> > 
> > Today's Topics:
> > 
> >     1. XO laptop as wireless remote terminal for Internet-in-a-Box
> >        (Nathan Riddle)
> > 
> > 
> > ----------------------------------------------------------------------
> > 
> > Message: 1
> > Date: Mon, 2 Dec 2019 11:35:44 -0500 (EST)
> > From: Nathan Riddle <xoap...@xoshare.org>
> > To: support-g...@lists.laptop.org
> > Subject: [support-gang] XO laptop as wireless remote terminal for
> >     Internet-in-a-Box
> > Message-ID: <1214647805.1373408.1575304544...@email.ionos.com>
> > Content-Type: text/plain; charset=UTF-8
> > 
> > An XO(*) laptop can be used as a wireless remote terminal for Internet-in-a 
> > box (IIAB) on a RaspberryPi computer.
> > 
> > Directly, the Browse Activity (or Firefox on XO's) is not compatible with 
> > IIAB; however, SSH with XO's X11 Forwarding (no sound) can display IIAB 
> > screens.
> > 
> > In August, a post by George Hunt demonstrated wifi "AP client" plus AP on 
> > Pi prompted a look at using wireless. Earlier, a USB wired connection was 
> > being used with SSH / X11 Forwarding.   A wireless connection was thought 
> > to have some advantages.
> > 
> > The full Debian Desktop has a Chromium Browser, so the SSH link starts 
> > Desktop /Chromium or Chromium Browser directly.   IIAB is then started in 
> > Chromium Browser. There is also access to a large part of the Debian 
> > Desktop.
> > 
> > Can anyone point to a way to start IIAB directly after SSH into RaspberryPi 
> > ??
> > 
> > Used was the standard method of setting up a wireless, headless Pi :   
> > connect Pi and XO to wireless router and ssh pi@raspberrypi (ip address 
> > 192.168.128.4) with XO laptop. Commands from the XO installed IIAB on a 
> > RaspberryPi Zero W.
> > 
> > Unfortunately, the AP client of George Hunt's shortcut would not survived 
> > IIAB installation and was abandoned for the simple method.   Still, wlan0 
> > survived, but was blocked without an inet address. IIAB had been configure 
> > for unblocked gateway.
> > 
> > Any suggestions for enabling wlan0 so internet service is available ??
> > 
> > Multiple (2) XO laptops can connect to IIAB AP and small programs, such as 
> > Terminal and Calculator, will work separately on each of the remotes. Large 
> > programs, such as Chromium and Libre Office when started on the second 
> > remote, just open another Tab on the first remote.   These are not server 
> > version programs, but the programs that appear to download do work.
> > 
> > Chromium is very slow and may be due to typing "lookahead" . By contrast, 
> > IIAB seems to run at a speed similar to the usual XO speed.   The wireless 
> > version, surprisingly, seems to run faster than the wired version.   On 
> > IIAB, the Content Menu takes a long time.
> > 
> > Nathan Riddle
> > 
> > 
> > ------------------------------
> > 
> > Subject: Digest Footer
> > 
> > _______________________________________________
> > support-gang mailing list
> > support-g...@lists.laptop.org
> > http://lists.laptop.org/listinfo/support-gang
> > 
> > 
> > ------------------------------
> > 
> > End of support-gang Digest, Vol 137, Issue 1
> > ********************************************
> 
> 
> _______________________________________________
> Sugar-devel mailing list
> Sugar-devel@lists.sugarlabs.org
> http://lists.sugarlabs.org/listinfo/sugar-devel

-- 
James Cameron
http://quozl.netrek.org/
_______________________________________________
Sugar-devel mailing list
Sugar-devel@lists.sugarlabs.org
http://lists.sugarlabs.org/listinfo/sugar-devel

Reply via email to