Mike C. Fletcher wrote: > Marco Pesenti Gritti wrote: >> What was you using the program name for? Maybe what you want is >> Activity.get_bundle_id(), at least I think that's what we used to set >> the program name to. (We had to give using the program name for this >> because there are libraries like xulrunner which mess with it). >> > This is from the olpcgames mesh.py module. It uses the name to > construct a "unique" DBUS service name for the various olpcgames-based > projects. That is, it tries to create a different name for each game > that uses the wrapper by asking for the program "name" and using that as > the DBUS name for the activity's sharing service. > > Substituting a call to get_bundle_id() seems to work fine in the sense > that it lets the code move past the import of the module and I can at
Please attach a patch to #4792. > least *seem* to share it (though TicTacToe.activity doesn't seem to > actually share any data). See #3907 which needs to be fixed before mesh.py could possibly work. olpcgames seems to be effectively unmaintained at the moment. Hope that helps, Morgan _______________________________________________ Sugar mailing list [email protected] http://lists.laptop.org/listinfo/sugar

