Hi Jakob

it was extremely helpful! Thank you very much!


Manoel Joaquim Rodrigues Barroso Neto

Bacharelando em Engenharia Civil

Universidade Federal de Juiz de Fora

(+55) 21-97255-8366
(+55) 32-98418-7950


________________________________
De: sumo-user-boun...@eclipse.org <sumo-user-boun...@eclipse.org> em nome de 
Jakob Erdmann <namdre.s...@googlemail.com>
Enviado: quinta-feira, 22 de fevereiro de 2018 05:15
Para: Sumo project User discussions
Assunto: Re: [sumo-user] Problems with guiShape attribute

Hello,
in your flow definitions you wrote attribute 'Type' with a capital T but it 
must be 'type'.
regards,
Jakob

2018-02-21 14:59 GMT+01:00 Manoel J. 
<manoelbarroson...@hotmail.com<mailto:manoelbarroson...@hotmail.com>>:

Hello all, thanks for receiving me here!

Guys, I tried to search for the same issue here on this forum, on the SUMO user 
documentation guide and other places on the internet but I didn't find a 
solution for that.
I'm trying to make work a simple simulation on a grid-net with three different 
flows.
For the network building, I used the NETGENERATE command, inputing these 
parameters:
File Name: net_.net.xml
=====================
<grid_network>
        <grid value="true"/>
        <grid.number value="5"/>
        <grid.length value="50"/>
        <grid.attach-length value="50"/>
</grid_network>
=====================
And for the demand modeling, I used the following code:
File Name: flows.rou.xml
=====================
<routes>
<vType id="bus" accel="2.6" decel="4.5" sigma="0.5" length="12" minGap="3" 
maxSpeed="20" color="0,0,1" vClass="bus" guiShape="bus"/>
<vType id="car" accel="2.6" decel="4.5" sigma="0.5" length="3.5" minGap="1.5" 
maxSpeed="22" color="1,1,0" vClass="passenger" guiShape="passenger"/>
<vType id="moto" accel="2.6" decel="4.5" sigma="0.5" length="2" minGap="1.0" 
maxSpeed="20" color="1,0,1" vClass="motorcycle" guiShape="motorcycle"/>

<route id="left_right" edges="left2to0/2 0/2to1/2 1/2to1/3 1/3to2/3 2/3to3/3 
3/3to4/3 4/3to4/4 4/4toright4" />
<route id="bottom_top" edges="bottom1to1/0 1/0to1/1 1/1to2/1 2/1to2/2 2/2to2/3 
2/3to1/3 1/3to1/4 1/4totop1" />
<route id="right_left" edges="right1to4/1 4/1to4/2 4/2to4/3 4/3to3/3 3/3to2/3 
2/3to1/3 1/3to0/3 0/3toleft3" />
<route id="top_bottom" edges="top0to0/4 0/4to1/4 1/4to1/3 1/3to1/2 1/2to2/2 
2/2to2/1 2/1to2/0 2/0tobottom2" />

<flow id="1" Type="car" period="10" begin="0" end="10000" color="0,0,1" 
route="esq_dir"/>
<flow id="2" Type="bus" period="10" begin="0" end="10000" color="1,1,0"  
route="cima_baixo"/>
<flow id="3" Type="moto" period="10" begin="0" end="10000" color="1,0,1" 
route="baixo_cima"/>

</routes>
=====================


To create a configuration file, I used as it follows:

File Name: CONFIGFLOW.sumocfg

=====================

<configuration>
    <input>
        <net-file value="net_.net.xml"/>
        <route-files value="flows.rou.xml"/>
    </input>
    <time>
        <begin value="0"/>
        <end value="10000"/>
    </time>
</configuration>
=====================

The simulations runs perfetcly, except from the fact that the shapes used on 
the real world simulation are all standards. I tried changing the guiShape 
several times with different codes but it just doesnt work, it keeps showing a 
regular passenger car in every flow, instead of displaying motorcycles, buses 
and passenger cars. The version I'm using is the latest version (0.32.0).
Can anyone help me with this guiShape thing?


Manoel Joaquim Rodrigues Barroso Neto

Bacharelando em Engenharia Civil

Universidade Federal de Juiz de Fora

(+55) 21-97255-8366<tel:+55%2021%2097255-8366>
(+55) 32-98418-7950<tel:+55%2032%2098418-7950>

_______________________________________________
sumo-user mailing list
sumo-user@eclipse.org<mailto:sumo-user@eclipse.org>
To change your delivery options, retrieve your password, or unsubscribe from 
this list, visit
https://dev.eclipse.org/mailman/listinfo/sumo-user


_______________________________________________
sumo-user mailing list
sumo-user@eclipse.org
To change your delivery options, retrieve your password, or unsubscribe from 
this list, visit
https://dev.eclipse.org/mailman/listinfo/sumo-user

Reply via email to