Hi Jakob,

thank you for looking into that. The problem seems to be minimized, but, 
unfortunately, when raising the demand, I can still observe the oscillating 
behavior with the current nightly snapshot (r25506). I added the same scenario 
with higher demand: 
https://syncandshare.lrz.de/dl/fiErEWR5TJnGw2hqCzygZRMW/minimal_test_fishtail_higherdemand.zip

When looking at AB_counter_truck.36 at simulation second 76.2 the blinkers and 
angels still show frequent changes. Should I just fix the parameters and if so, 
how is the relation between the different values to prevent this behavior?

Thanks again for the great work, the sublane feature is very helpful!

Jakob




Von: Jakob Erdmann [mailto:namdre.s...@googlemail.com]
Gesendet: Montag, 7. August 2017 14:55
An: Kaths, Jakob <jakob.ka...@tum.de>
Cc: sumo-user@lists.sourceforge.net
Betreff: Re: [sumo-user] Swerving / fishtailing of vehicles when using sublane 
model

Thank you for providing the example scenario. The issue 
(http://sumo.dlr.de/trac.wsgi/ticket/3333) is fixed in revision [25500].
The relevant aspect of your scenario for exposing this problem was a mismatch 
between lane width, vehicle width and the minGapLat attribute (default 1.0m). 
In your scenario, the vehicles were unable to maintain their minimum preferred 
lateral gaps even when driving in the center of their lane. Setting vType 
attribute minGapLat="0.8" would also mitigate the issue.
regards,
Jakob

2017-07-25 10:48 GMT+02:00 Kaths, Jakob 
<jakob.ka...@tum.de<mailto:jakob.ka...@tum.de>>:
Hi,

I hope I prepared a meaningful and minimal enough example. It can be downloaded 
here: 
https://syncandshare.lrz.de/dl/fiMpaoK6ajFTxaMLLcs5czyX/minimal_test_fishtail.zip

For example AB_counter_car.3 leaves the network straight on the second lane, 
whereas AB_counter_car.27 alternates between 203.88 degrees and 205.86 degrees 
from step 69.1 on.
The alternating indicators can be seen on some of the trucks. With curved 
networks and more variable traffic, the effects become more obvious though.

I hope that helps, let me know, if I can provide anything else.

Thanks again

Jakob

Von: Jakob Erdmann 
[mailto:namdre.s...@googlemail.com<mailto:namdre.s...@googlemail.com>]
Gesendet: Dienstag, 25. Juli 2017 14:36

An: Kaths, Jakob <jakob.ka...@tum.de<mailto:jakob.ka...@tum.de>>
Cc: sumo-user@lists.sourceforge.net<mailto:sumo-user@lists.sourceforge.net>
Betreff: Re: [sumo-user] Swerving / fishtailing of vehicles when using sublane 
model

Hello,
fluctuation decisions indicate a bug in the sublane lane-change model. You can 
help to get this fixed by providing a minimal example scenario (the fewer 
vehicles and edges the better).
regards,
Jakob

2017-07-25 6:10 GMT+02:00 Kaths, Jakob 
<jakob.ka...@tum.de<mailto:jakob.ka...@tum.de>>:
Hi,

sorry to warm this topic up again. I’ve been looking a bit more into it again 
and I definitely see some improvement, but the behavior of the sublane model 
with 0.1 s step still leads to a frequent change in the sign of the yaw rate of 
vehicles. Furthermore, for some vehicles, there seem to be fluctuating 
decisions about lane changes, so each step they redecide and the indicators 
blink right and left alternating each step.
Is this still considered a bug or just the nature of the sublane lane-change 
model? If the latter is the case, are there suggested parameter sets to damp 
this behavior?

Thanks a lot for your suggestions

Jakob

Von: Kaths, Jakob
Gesendet: Freitag, 14. Juli 2017 13:18
An: sumo-user@lists.sourceforge.net<mailto:sumo-user@lists.sourceforge.net>
Cc: 'Jakob Erdmann' 
<namdre.s...@googlemail.com<mailto:namdre.s...@googlemail.com>>
Betreff: AW: [sumo-user] Swerving / fishtailing of vehicles when using sublane 
model

Sorry, I should have tried the latest developer version first. Looks a lot 
better on first glance! Thanks!

Von: Jakob Erdmann [mailto:namdre.s...@googlemail.com]
Gesendet: Donnerstag, 13. Juli 2017 14:10
An: Kaths, Jakob <jakob.ka...@tum.de<mailto:jakob.ka...@tum.de>>
Cc: sumo-user@lists.sourceforge.net<mailto:sumo-user@lists.sourceforge.net>
Betreff: Re: [sumo-user] Swerving / fishtailing of vehicles when using sublane 
model

Hello,
this is due to a bug which has been fixed in the latest development version.
regards,
Jakob

2017-07-13 8:05 GMT+02:00 Kaths, Jakob via sumo-user 
<sumo-user@lists.sourceforge.net<mailto:sumo-user@lists.sourceforge.net>>:
Hi everybody,

I know there have been some bugfixes in this area lately, but still I observe 
somewhat odd behavior when using the sublane model. Especially longer vehicles 
(trucks, busses) in some parts of my network seem to fishtail/swerve for no 
apparent reason. They perform oscillating angle changes, which makes them 
"wiggle" without actually changing lanes. I set the lateral resolution to 0.5, 
the step size to 0.1 and I'm using the SUMO 0.30.0 release.
Are there any hints on how to avoid this behavior? I tried adjusting the 
lateral speed (to 0.1), but it doesn't help.

Thanks!

Jakob

--
Dipl.-Ing. Jakob Kaths

Technische Universität München
Ingenieurfakultät Bau Geo Umwelt
Lehrstuhl für Verkehrstechnik
Univ.-Prof. Dr.-Ing. Fritz Busch

jakob.ka...@tum.de<mailto:jakob.ka...@tum.de><mailto:jakob.ka...@tum.de<mailto:jakob.ka...@tum.de>>
www.vt.bgu.tum.de<http://www.vt.bgu.tum.de><http://www.vt.bgu.tum.de/>


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
sumo-user mailing list
sumo-user@lists.sourceforge.net<mailto:sumo-user@lists.sourceforge.net>
https://lists.sourceforge.net/lists/listinfo/sumo-user



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
sumo-user mailing list
sumo-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/sumo-user

Reply via email to