Michael Gordon wrote:
We have an interesting problem that surfaced recently and needs some attention.

We have a graphics program called Paint Shop Pro XI that is supposed to allow us to send an open and active image as an attached file in our e-mail application.

When we press the File/E-mail button we get an error from PSP that an unknown error has occurred and nothing else happens.

If SeaMonkey Mail is open to receive messages and we perform the above steps a new compose message window opens with the image file in the attach file box and everything works correctly.

In SeaMonkey Mail Preferences SeaMonkey Mail is the default mail client, in Windows XP Control Panel/Internet Options/Programs SeaMonkey Mail is the default mail client.

Any ideas or suggestions?

Michael Gordon

This looks like a "Paint Shop Pro XI" problem.
When you press the File/E-mail button "Paint Shop Pro XI" did not check if SM is up and running ... he just try to communicate with him.

IMHO - The best way of working of ""Paint Shop Pro XI" when you press the File/E-mail button must be:
1. Check if SM is up and running : if yes got to step 6.
2. Start SM.
3. Wait until SM is up and running if yes go to step 6.
4. if the accepted delay of starting SM is not reached go to step 3.
5. Display "impossible to start SM" print stopped.
6. Communicate with SM to send the mail.
...
_______________________________________________
support-seamonkey mailing list
support-seamonkey@lists.mozilla.org
https://lists.mozilla.org/listinfo/support-seamonkey

Reply via email to