On Monday 22 September 2008 10:44, skx wrote:
> How can I get Freenet to start when system starts? 
> I tried Freenet_enable="YES" in rc.conf and @reboot entries in crontab but 
> it seems that Freenet starts too early and it is missing dependencies. 
> Then I wrote my own script to run run.sh with a slight delay
> #! /bin/sh
> sleep 90
> sh /usr/freenet/freenet/run.sh start
> and put 
> @reboot /usr/freenet/freenet.sh
> in freenet's crontab but it still doesn't start on boot. 
> I am using FreeBSD 7, have freenet installed in /usr/freenet/freenet and 
> run it as user freenet. It works perfectly well (including binding to 
> port 80 and custom ip address, great piece of software) when run 
> manually. 

Have you tried cd'ing to the directory first?

Have you checked permissions?

Let us know if you find an answer...
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 827 bytes
Desc: not available

Reply via email to